0 Replies Latest reply on Nov 29, 2016 4:30 AM by Deepak S

    JBOSS EAP 6.3 ERROR while Editing BPMN file

    Deepak S Newbie

      Hi,

      We have JBOSS EAP 6.3 installed on a LINUX box. We have the jbpm-console.war deployed on it using the jbpm-installer.

      The jbpm instance points to a separate ORACLE instance. Also it is a clustered JBPM environment where we have 4 servers with JBPM repositories replicated on them.

       

      Problem:-

      When we go to the JBPM console for changing a BPMN file on a particular node, we are seeeing that the BPMN file is not getting rendered at all. We tried with admin credential as well, still It did not work. Out of the 4 servers we observed that the BPMN file did not render on 3 servers. On the fourth server, it got rendered intermittently. Below is the error which is observed while rendering the BPMN file

       

      java.lang.classcastexception: org.eclipse.emf.ecore.impl.EAttributeImpl cannot be cast to org.eclipse.emf.ecore.EReference

      Also provided error in the attachment.

       

      Errors seen in the logs at the same time:-

        06:53:24,728 ERROR [org.jbpm.designer.web.preprocessing.impl.JbpmPreprocessingUnit] (http-/0.0.0.0:8443-5) There is already a batch process to this thread

        06:53:24,007 ERROR [org.jbpm.designer.web.preprocessing.impl.JbpmPreprocessingUnit] (http-/0.0.0.0:8443-5) null

       

      We tried re-starting the JBOSS server, still it gave the same error while rendering the bpmn file on console.

       

      Any one has any idea about this issue with JBPM on JBOSS EAP 6.3, any quick updates will help me.

       

      Thx