1 Reply Latest reply on Aug 24, 2001 5:46 PM by Patrick

    lookup() problem

    Jari Kujansuu Newbie


      Hi,

      I have little problem, might be stupid too.. but can't seem to find answer from documents or specs. We have been running and testing our
      Jboss server on Linux and everything have been working fine. But today tried running it on Win2000 and got error when bean tried to
      locate another with InitialContext.lookup()

      What I am looking for is bean named "NovaCodia/security/CredentialManager"

      And bean has looked it with method call lookup("/NovaCodia/security/CredentialManager")

      Now in windows got exception complaining about no protocol..

      According to EJB 1.1 specs (I think that) I should use lookup("java:comp/env/ejb/NovaCodia/security/CredentialManager") ..even that any other documentation that I have doesn't use it that way.

      But get NamingException says that ejb is not bound.. so that doesn't sound right.

      If someone could help me with this little problem I would be happy..