8 Replies Latest reply on Jan 6, 2017 11:20 AM by Seto Kaiba

    WildFly and Hibernate module problem.

    Seto Kaiba Expert


      I downloaded hibernate module and extracted to modules/system/layers/base.

      <property name="jboss.as.jpa.providerModule" value="org.hibernate:5.2" />

      And add this line to persistence-unit to make it use hibernate 5.2 module. Then it reports the exception below.

      Caused by: java.util.ServiceConfigurationError: org.hibernate.integrator.spi.Integrator: Provider org.hibernate.search.hcore.impl.HibernateSearchIntegrator not a subtype