0 Replies Latest reply on Jan 5, 2017 2:12 AM by Sumeeth Tewar

    Trying to deploy seam 2.3 application on wildfly 10.1 -getting class cast errors.

    Sumeeth Tewar Newbie

      Hi I am trying to deploy a seam 2.3 application on wildfly 10.1 I am getting class cast errors as follows :

       

       

       

       

      {    "WFLYCTL0080: Failed services" => {"jboss.undertow.deployment.default-server.default-host./harvesting" => "org.jboss.msc.service.StartException in service jboss.undertow.deployment.default-server.default-host./harvesting: java.lang.RuntimeException: java.lang.RuntimeException: error while reading /WEB-INF/components.xml

          Caused by: java.lang.RuntimeException: java.lang.RuntimeException: error while reading /WEB-INF/components.xml

          Caused by: java.lang.RuntimeException: error while reading /WEB-INF/components.xml

          Caused by: org.dom4j.DocumentException: SAX2 driver class __redirected.__XMLReaderFactory does not implement XMLReader Nested exception: SAX2 driver class __redirected.__XMLReaderFactory does not implement XMLReader"},

          "WFLYCTL0412: Required services that are not installed:" => ["jboss.undertow.deployment.default-server.default-host./harvesting"],

          "WFLYCTL0180: Services with missing/unavailable dependencies" => undefined

      }

       

      checked that the __redirected.__XMLReaderFactory is present inside jboss-modules.jar,

       

      is there a way I can guarantee that the above class is not used?

       

       

      I tried adding the exclusions to jboss-deployment-descriptor xml but of no use :

       

       

      <exclusions>

         

              <module name="org.jboss.modules"/>

          </exclusions>

       

      Please let me know how do I make this work?

      If there is any way seam 2.3 works on Wildfly 10.1 please guide me to the tutorial/Page.

       

       

      Thanks!