1 Reply Latest reply on Jan 14, 2017 4:41 AM by Anup Dey

    JBOSS EAP

    ghanshyam goliwadekar Newbie

      We are on JBOSS EAP 6.4.

       

      Deployment of EAR to this used to work previously. We are trying to deploy newer version of EAR (which uses JDK8 instead of JDK7).

      While deploying a EAR, we get following error:

       

      service jboss.deployment.subunit."smcfs.ear"."sma.war".INSTALL: JBAS018733: Failed to process phase INSTALL of subdeployment "sma.war" of deployment "smcfs.ear"

        at org.jboss.as.server.deployment.DeploymentUnitPhaseService.start(DeploymentUnitPhaseService.java:166) [jboss-as-server-7.5.0.Final-redhat-21.jar:7.5.0.Final-redhat-21]

        at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1980) [jboss-msc-1.1.5.Final-redhat-1.jar:1.1.5.Final-redhat-1]

        at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1913) [jboss-msc-1.1.5.Final-redhat-1.jar:1.1.5.Final-redhat-1]

        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142) [rt.jar:1.8.0_51]

        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617) [rt.jar:1.8.0_51]

        at java.lang.Thread.run(Thread.java:745) [rt.jar:1.8.0_51]

      Caused by: java.lang.IllegalArgumentException: Empty name segment is not allowed for security-domain

        at org.jboss.msc.service.ServiceName.of(ServiceName.java:90) [jboss-msc-1.1.5.Final-redhat-1.jar:1.1.5.Final-redhat-1]

        at org.jboss.msc.service.ServiceName.append(ServiceName.java:117) [jboss-msc-1.1.5.Final-redhat-1.jar:1.1.5.Final-redhat-1]

        at org.jboss.as.web.deployment.WarDeploymentProcessor.processDeployment(WarDeploymentProcessor.java:299)

        at org.jboss.as.web.deployment.WarDeploymentProcessor.deploy(WarDeploymentProcessor.java:126)

        at org.jboss.as.server.deployment.DeploymentUnitPhaseService.start(DeploymentUnitPhaseService.java:159) [jboss-as-server-7.5.0.Final-redhat-21.jar:7.5.0.Final-redhat-21]

        ... 5 more

       

      Not able to figure out what can cause this issue. Do we need to make additional changes in JBOSS to use JDK8?

        • 1. Re: JBOSS EAP
          Anup Dey Apprentice

          Hi,

           

          Locate the deployment descriptor in the application containing security-domain and correct the deployment descriptor. Remove the element or put the correct configuration inside of the element.

           

          A deployment descriptor contains an empty element such as:

           

          ~~~

          <security-domain/>

          ~~~

           

          When JBoss is expecting some text inside it such as:

          ~~~

          <security-domain>my-domain</security-domain>

          ~~~

           

          Try it.