1 Reply Latest reply on Jan 23, 2017 7:47 AM by Anup Dey

    JBoss EAP 6.4.5 and Saxparser 1.0

    Hemen Thacker Newbie

      Hi

       

      Is there anyway to ensure JBoss uses Saxparser 1.0 for my deployed war and not give following exception?

       

      I have provided all the classpath jars in modules and set dependency to module in jboss-deployment-structure.xml

       

      I still see following error in log when servlet tryies to load the XMLs.

       

      java.lang.ClassCastException: __redirected.__XMLReaderFactory cannot be cast to org.xml.sax.XMLReader
      at org.xml.sax.helpers.XMLReaderFactory.loadClass(Unknown Source) [rt.jar:1.8.0_66]