2 Replies Latest reply on Aug 16, 2017 2:01 PM by Pitaks Klinthong

    Redhat EAP 6.4 jconsole domain controller jboss.as model missing

    David Gilbert Newbie

      I am having an issue that only seems to happen in EAP 6.4 in domain mode. Standalone mode works fine and later versions all work.

       

      I set up EAP 6.4 in domain mode.

       

      I did the standard config:

       

      /profile=full/subsystem=jmx/remoting-connector=jmx:add(use-management-endpoint=false)

       

      Using jconsole I can connect with no issues to the following service URLs

       

      service:jmx:remoting-jmx://<hostname>:9999

       

      service:jmx:remoting-jmx://<hostname>:4447

       

      The issue is that when I connect to the domain controller at the 9999 port I see no jboss.as or jboss.as.expr in jconsole on the Mbean tab.

       

      I see it fine in standalone mode and on the servers (in domain mode)

       

      It is my understanding that <expose-resolved-model/> and <expose-expression-model/> control the jboss model being shown.

       

       

                <subsystem xmlns="urn:jboss:domain:jmx:1.3">

                      <expose-resolved-model/>

                      <expose-expression-model/>

                      <remoting-connector use-management-endpoint="false"/>

                  </subsystem>

       

      I hope this is not a "feature" of domain mode on the domain controller. My application needs to query the domain controller to determine the server groups and servers. This is going to be a serious limitation if I can't get access to the jboss.as model through the domain controller.

       

       

              David