1 Reply Latest reply on Mar 24, 2017 3:29 AM by Panagiotis Chavariotis

    No ModelControllerClient was available to execute the request

    Jimmy Murillo Newbie

      I'm trying to install JBoss BRMS 6.4 following the standard procedure that gave me succesfull results, but in this installation permanently show the same error message that interrupt the installation with failure:

       

      Java HotSpot(TM) 64-Bit Server VM warning: ignoring option MaxPermSize=256m; support was removed in 8.0

      12:33:00,992 INFO  [org.jboss.modules] (main) JBoss Modules version 1.3.6.Final-redhat-1

      12:33:01,137 INFO  [org.jboss.msc] (main) JBoss MSC version 1.1.5.Final-redhat-1

      12:33:01,221 INFO  [org.jboss.as] (MSC service thread 1-7) JBAS015899: JBoss EAP 6.4.0.GA (AS 7.5.0.Final-redhat-21) starting

      12:33:02,109 INFO  [org.xnio] (MSC service thread 1-6) XNIO Version 3.0.13.GA-redhat-1

      12:33:02,112 INFO  [org.jboss.as.server] (Controller Boot Thread) JBAS015888: Creating http management service using socket-binding (management-http)

      12:33:02,118 INFO  [org.xnio.nio] (MSC service thread 1-6) XNIO NIO Implementation Version 3.0.13.GA-redhat-1

      12:33:02,140 INFO  [org.jboss.remoting] (MSC service thread 1-1) JBoss Remoting version 3.3.4.Final-redhat-1

      12:33:02,183 INFO  [org.jboss.as.remoting] (MSC service thread 1-6) JBAS017100: Listening on 127.0.0.1:9999

      12:33:02,221 INFO  [org.jboss.as] (Controller Boot Thread) JBAS015961: Http management interface listening on http://127.0.0.1:9990/management

      12:33:02,222 INFO  [org.jboss.as] (Controller Boot Thread) JBAS015954: Admin console is not enabled

      [ Server code detected: JBAS015874 ]

      Waiting for server to be ready. This could take up to 40 seconds.

      Application Server successfully started.

      Starting process Querying server for jboss.server.data.dir (8/58)

      Trying to connect to Management Interface...(1/5).

      Mar 23, 2017 12:33:05 PM org.xnio.Xnio <clinit>

      INFO: XNIO Version 3.0.13.GA-redhat-1

      Mar 23, 2017 12:33:05 PM org.xnio.nio.NioXnio <clinit>

      INFO: XNIO NIO Implementation Version 3.0.13.GA-redhat-1

      Mar 23, 2017 12:33:05 PM org.jboss.remoting3.EndpointImpl <clinit>

      INFO: JBoss Remoting version 3.3.4.Final-redhat-1

      Trying to connect to Management Interface...(2/5).

      Trying to connect to Management Interface...(3/5).

      Trying to connect to Management Interface...(4/5).

      Trying to connect to Management Interface...(5/5).

      Failed to connect to Management Interface after 5 attempts.

      Starting process Writing initial server properties (9/58)

      Trying to connect to Management Interface...(1/5).

      Trying to connect to Management Interface...(2/5).

      Trying to connect to Management Interface...(3/5).

      Trying to connect to Management Interface...(4/5).

      Trying to connect to Management Interface...(5/5).

      Failed to connect to Management Interface after 5 attempts.

      Advanced configuration command failed: /system-property=org.kie.server.repo:add(value=${jboss.server.data.dir})

      {

      "outcome" => "failed",

      "failure-description" => "No ModelControllerClient was available to execute the request.",

      "command" => "/system-property=org.kie.server.repo:add(value=${jboss.server.data.dir})"

      }

      Advanced configuration command failed: /system-property=org.jbpm.server.ext.disabled:add(value=true)

      {

      "outcome" => "failed",

      "failure-description" => "No ModelControllerClient was available to execute the request.",

      "command" => "/system-property=org.jbpm.server.ext.disabled:add(value=true)"

      }

      Advanced configuration command failed: /system-property=org.jbpm.ui.server.ext.disabled:add(value=true)

      {

      "outcome" => "failed",

      "failure-description" => "No ModelControllerClient was available to execute the request.",

      "command" => "/system-property=org.jbpm.ui.server.ext.disabled:add(value=true)"

      }

      Starting process Onfail Server Shutdown Job (10/58)

      Running on-fail server check.

      Shutting server down.

      Trying to connect to Management Interface...(1/5).

      Trying to connect to Management Interface...(2/5).

      Trying to connect to Management Interface...(3/5).

      Trying to connect to Management Interface...(4/5).

      Trying to connect to Management Interface...(5/5).

      Failed to connect to Management Interface after 5 attempts.

      {"outcome" => "failed","failure-description" => "No ModelControllerClient was available to execute the request.","command" => ":shutdown"}

      Starting process Copy server logs (11/58)

      Successfully moved source: /root/EAP-6.4.0/standalone/log/server.log to destination: /root/EAP-6.4.0/installation/server-logs

      The configured source file: /root/EAP-6.4.0/domain/log/host-controller.log doesn't exist.

      The configured source file: /root/EAP-6.4.0/domain/log/process-controller.log doesn't exist.

      Installation has failed.

      [ Console installation done ]

       

      I tryed the installation over a new EAP 6.4.0 installation and a new EAP 6.4.8 installation too. No changes made over EAP before start BRMS installation.

       

      Have someone any idea about the issue that impede the BRMS installation? Thank you.