0 Replies Latest reply on Sep 21, 2001 4:33 PM by Kenney Westerhof

    NoClassDefFoundError: $Proxy12

    Kenney Westerhof Newbie

      Hi there,

      My setup:
      machine A with jdk 1.4, jboss 2.4.0+tomcat 3.2.3,
      machine B with jdk 1.3.1, same jboss+tomcat

      On machine A I run a servlet which tries to lookup
      a bean on machine B. The ear is deployed correctly.

      When I run a class on machine A from the commandline
      which does the same as the servlet, it works fine.
      When the code is executed from within the servlet,
      I get this stacktrace:

      [Default] DEBUG : 2001/09/21 21:54 [m3u] looking up StreamManager
      [EmbeddedTomcatSX] 2001-09-21 21:54:28 - Ctx( neostream.neonics.com: ): Exception in: R( + + /stream/track532.m3u) - java.lang.NoClassDefFoundError: $Proxy12
      at sun.reflect.GeneratedSerializationConstructorAccessor51.newInstance(Unknown Source)
      at java.lang.reflect.Constructor.newInstance(Constructor.java:273)
      at java.io.ObjectStreamClass.newInstance(ObjectStreamClass.java:680)
      at java.io.ObjectInputStream.readOrdinaryObject(ObjectInputStream.java:1550)
      at java.io.ObjectInputStream.readObject0(ObjectInputStream.java:1202)
      at java.io.ObjectInputStream.readObject(ObjectInputStream.java:297)
      at java.rmi.MarshalledObject.get(MarshalledObject.java:138)
      at org.jnp.interfaces.NamingContext.lookup(NamingContext.java:353)
      at org.jnp.interfaces.NamingContext.lookup(NamingContext.java:333)
      at javax.naming.InitialContext.lookup(InitialContext.java:350)
      at com.neonics.neostream.webserver.m3u.registerStream(m3u.java:205)
      at com.neonics.neostream.webserver.m3u.handleTrack(m3u.java:175)
      at com.neonics.neostream.webserver.m3u.handleTrack(m3u.java:153)
      at com.neonics.neostream.webserver.m3u.handleTrack(m3u.java:122)
      at com.neonics.neostream.webserver.m3u.run(m3u.java:62)
      ......


      I checked via port 8082, MBeanView, and the beans are
      correctly deployed and their classnames are $ProxyX where is is 4,6,7,8, not 12 as stated in the exception.
      Cannot find any class with name $Proxy12 on machine B's environment..

      I have a jar that contains all the project's classfiles, including the beans, interface and home interface files. So that's not the problem (or I must have done something wrong..) That jar is in the WEB-INF/lib directory of my servlet zone.

      Any ideas?

      PS: I create a new InitialContext with the 3 properties
      in the jndi.properties file, with the ip adress of Machine B (on machine A). tcpdump shows that there indeed are connections made to machine B from machine A...

      Thanks in advance for any help.