2 Replies Latest reply on Apr 11, 2017 2:17 AM by Nikolaos Bartsotas

    EJB2 SFSB Wildfly 10

    Nikolaos Bartsotas Newbie

      Hello,

      We are trying to migrate our application from Jboss 6 to Wildfly 10.1

      The application has some EJB2 SFSB which return the following error when we are trying to deploy it:

       


      16:26:51,673 ERROR [org.jboss.as.controller.management-operation] (DeploymentScanner-threads - 1) WFLYCTL0013: Operation ("deploy") failed - address: ([("deployment" => "sma-ear.ear")]) - failure description: {

       

          "WFLYCTL0412: Required services that are not installed:" => [

              "jboss.deployment.subunit.\"sma-ear.ear\".\"SMA_EJBs.jar\".component.PMSStatusStatsGraphSes.cache",

              "jboss.deployment.subunit.\"sma-ear.ear\".\"SMA_EJBs.jar\".component.GraphSes.cache",

              "jboss.deployment.subunit.\"sma-ear.ear\".\"SMA_EJBs.jar\".component.GraphGenSes.cache"

          ],

      The

      PMSStatusStatsGraphSes

      GraphSes

      GraphGenSes

      are the names of the SFSB's.

      What is more, when we deploy our application on wildfly 9, it looks like they work, though not efficiently.

      Can anyone help us with it?