4 Replies Latest reply on Apr 19, 2017 8:21 AM by Rick Wagner

    rh-dotnetcore11 package seems to be out of date

    Werner Strydom Newbie

      I'm trying to create a build process for a ASP.NET Core application that was created using Visual Studio 2017 on Windows 10.

       

      cd src
      dotnet restore
      dotnet build
      

       

      This has been automated using build.cmd.

       

      My next objective is to create a build.sh for RHEL 7, which would end up with an RPM.  To prepare for that I did the following:

       

      1. Create an RHEL 7.3 virtual machine
      2. Followed the instructions to install dotnet core 1.1 in the VM. 

       

      I then ran the following commands on Windows 10 to create a self-contained deployment.

       

      dotnet restore --runtime rhel.7-x64
      dotnet publish --framework netcoreapp1.1 --runtime rhel.7-x64
      

       

      I then SFTP the output over to the VM and the application works as expected.

       

      I then cloned the project to the RHEL VM and then tried to execute the following commands:

       

      cd src
      dotnet restore
      dotnet build
      

       

      However it failed with the following errors:

       

      [werners@localhost src]$ dotnet restore
      warn : The folder '/home/werners/development/hello/src' does not contain a project to restore.
      [werners@localhost src]$ dotnet build
      Couldn't find 'project.json' in current directory
      [werners@localhost src]$
      

       

      This looks rather suspicious.  So I logged out and logged back in and the ran the following commands:

       

      [werners@localhost ~]$ scl enable rh-dotnetcore11 bash
      [werners@localhost ~]$ dotnet --version
      1.0.0-preview2-1-003176
      

       

      On Windows, the version returns the following:

       

      S:\hello\src>dotnet --version
      1.0.3
      

       

      So it looks like rh-dotnetcore11 doesn't have the latest released version of .NET core command line.

       

      To validate, I ran the following as root.

       

      [root@localhost ~]# yum install rh-dotnetcore11
      Loaded plugins: langpacks, product-id, search-disabled-repos, subscription-manager
      Package rh-dotnetcore11-1.0-1.el7.x86_64 already installed and latest version
      Nothing to do
      

       

      What am I missing?