1 Reply Latest reply on Apr 24, 2017 9:20 AM by George Gastaldi

    Is Gradle Support deprecated?

    David Laurentino Newbie

      I have installed in my Ubuntu:

       

      Gradle 3.5

      Forge 3.6.1

      Forge Gradle addon 3.0.0

       

      When I try run project-new command with "--build-system Gradle", an exception occur:

       

      Facet type [org.jboss.forge.addon.gradle.projects.facets.GradleJavaCompilerFacet] could not be installed into [org.jboss.forge.addon.gradle.projects.GradleProject@1ee92cb1] of type [org.jboss.forge.addon.gradle.projects.GradleProject]. You may wish to check for inconsistent origin state as partial installation may have occurred.

       

      However, if I unset GRADLE_HOME environment variable before run the forge, it works as expected. That way, it seems like the addon ignores the installed Gradle and automaticaly download an unknow version of Gradle.

       

      It seems like Forge Gradle Addon doesn't work with most recent versions of Gradle. Am I right about this or can there be something wrong in my system?

       

      Sorry my bad english.