4 Replies Latest reply on Apr 25, 2017 1:10 PM by Tomaz Cerar

    Jboss AS6 to Wildfly 8 Upgrade

    Ashwini P Newbie

      Hello everyone,

       

      I am trying to upgrade from Jboss AS 6 to Wildfly 8 in the same linux box.

      Current Jboss AS 6 uses jdk 1.6. and I want to upgrade from jdk 1.6 to 1.8 and Jboss AS 6 to Wildfly 8 without disturbing the current running JBoss AS 6.

       

      I downloaded jdk1.8 and Wildfly 8. When I try to run add-user.sh, it shows java version error below as:

       

      Exception in thread "main" java.lang.UnsupportedClassVersionError: org/jboss/as/domain/management/security/adduser/AddUser : Unsupported major.minor version 51.0

       

      My question is, how to use 2 different versions of jdks' and Jboss in same machine.

      What are the files do I need to update so that Wildfly 8 picks up Jdk1.8 ? (Using standalone mode)

       

      Thanks in advance.