0 Replies Latest reply on May 2, 2017 12:25 PM by Murat Şener

    java.io.FileNotFoundException: Source 'D:\JBoss\EAP-7.0.0\bin\content\eArsiv.war\WEB-INF\lib\lept4j-1.2.3.jar\win32-x86-64' does not exist

    Murat Şener Newbie

      Greetings,

      I was developing an application with Spring Boot and using tess4j for OCR process. It was jar packaging and working well.

      I just changed packaging to war and deployed to jBoss EAP7.Now i am getting "Source 'D:\JBoss\EAP-7.0.0\bin\content\eArsiv.war\WEB-INF\lib\lept4j-1.2.3.jar\win32-x86-64' does not exist" error and TessAPI cant be initialized.

      Normally there is no folder as content under bin folder but anyway i have created subfolders under bin folder but still no chance.

       

      I also tried to deploy Spring Application  to Tomcat 9, it didnt work well in first try and then i added dll files to project folder just like posted in this link : java - Tess4J error after distributing as war NoClassDefFoundError: Could not initialize class net.sourceforge.tess4j.Te…

      now it is working well in Tomcat 9 but still no chance in jBoss EAP 7.

      Could you guys help me handle this case?

      Many thanks in advance!

      Cheers,

      Murat