2 Replies Latest reply on May 10, 2017 3:56 AM by David Gilbert

    JBoss AS 7.1.1 with Java 6 fails to deploy applications on Aix 5.3

    David Gilbert Newbie

      Hello everybody;

       

      For a customer, I have installed my application with WildFly 9 on several servers except one.

       

      One server cannot install Java 7 because of an older Aix version (5.3). They cannot upgrade the server quickly because it's a production server.

      So, instead of Wildfly 9, I installed JBoss 7.1.1 (because our application is also compliant with this version).

       

      The issue is : the deployment of my application (2 war files and a rar file) doesn't work.

       

      It worked 2 weeks ! And now it doesn't work anymore, without changing anything.

      On another similar environment, I had troubles to make it work, then it worked, and now it doesn't work anymore.

       

      Symptomes are :

      1- JBoss starts, the console is available and working.

      2- But when it tries to deploy my applications, it finishes with a .failed after timeout.

       

      There is no error message except timeout messages (even with TRACE mode) :

       

      server.log :

      16:48:13,458 ERROR [org.jboss.as.controller.management-operation] (DeploymentScanner-threads - 2) Operation ("add") failed - address: ([("deployment" => "VDWScreen.war")]) - failure description: "Operation cancelled asynchronously"

       

      deployment.log :

      16:46:13,448 DEBUG [org.jboss.as.server.deployment.scanner] (DeploymentScanner-threads - 1) Deployment scan of [/gold_prd/vocal601/jboss/standalone/deployments] found update action [{

          "operation" => "composite",

          "address" => undefined,

          "steps" => [

              {

                  "operation" => "add",

                  "address" => [("deployment" => "VDWScreen.war")],

                  "content" => [{

                      "path" => "deployments/VDWScreen.war",

                      "relative-to" => "jboss.server.base.dir",

                      "archive" => true

                  }],

                  "persistent" => false

              },

              {

                  "operation" => "deploy",

                  "address" => [("deployment" => "VDWScreen.war")]

              }

          ]

      }]

      16:48:13,455 ERROR [org.jboss.as.server.deployment.scanner] (DeploymentScanner-threads - 1) JBAS015052: Did not receive a response to the deployment operation within the allowed timeout period [120 seconds]. Check the server configuration file and the server logs to find more about the status of the deployment.

       

      Deleting temporary files didn't solve the issue.

       

      Same war and rar files are working well on Wildfly with Java 7.

      They are compiled with a Java 6 SDK

       

      Java version on the server is :

       

      java version "1.6.0"

      Java(TM) SE Runtime Environment (build pap6460-20071123_01)

      IBM J9 VM (build 2.4, J2RE 1.6.0 IBM J9 2.4 AIX ppc64-64 jvmap6460-20071121_15015 (JIT enabled)

      J9VM - 20071121_015015_BHdSMr

      JIT  - r9_20071121_1330

      GC   - 20071031_AA)

      JCL  - 20071118_01

       

      I tested a lot of things but nothing worked.

      Any suggestions ?