2 Replies Latest reply on Jun 1, 2017 11:18 AM by Zach Visagie

    Unsatisfied field dependency @Default org.jboss.errai.security.client.local.storage.UserStorageHandler

    Zach Visagie Newbie

      Hi

       

      After upgrading from 4.0.0.Beta4 to 4.0.0.Final I get the following exception when compiling in super dev mode. In Eclipse I can compile from the gui without problem. Previously errai generators didn't seem to run at all in super dev mode which is why I upgraded.

       

      java.util.concurrent.ExecutionException: java.lang.RuntimeException: The following dependency problems were found:

          Unsatisfied field dependency @Default org.jboss.errai.security.client.local.storage.UserStorageHandler for Class @Any @Default org.jboss.errai.security.client.local.context.BasicUserCacheImpl.

       

          at java.util.concurrent.FutureTask.report(FutureTask.java:122)

          at java.util.concurrent.FutureTask.get(FutureTask.java:192)

          at org.jboss.errai.config.rebind.AsyncGenerators$FutureWrapper.get(AsyncGenerators.java:112)

          at org.jboss.errai.config.rebind.AsyncGenerators$FutureWrapper.get(AsyncGenerators.java:86)

          at org.jboss.errai.config.rebind.AbstractAsyncGenerator.startAsyncGeneratorsAndWaitFor(AbstractAsyncGenerator.java:205)

          at org.jboss.errai.ioc.rebind.ioc.bootstrapper.IOCGenerator.generate(IOCGenerator.java:62)

          at com.google.gwt.core.ext.IncrementalGenerator.generateNonIncrementally(IncrementalGenerator.java:40)

       

      I am using Keycloak as per the tutorial in the reference guide.

       

      Any help or pointers appreciated. I am fairly new to errai (few weeks), CDI and wildfly, but have been working with GWT, Spring and Tomcat for a few years.