0 Replies Latest reply on Jun 2, 2017 3:20 AM by Sistic Infra Team

    Slow performance on production server

    Sistic Infra Team Newbie

      Hi JBoss developer,

       

      We had encountered slow performance in the jBosss with warning log below. Currently, we had change the config setting as a workaround.

      Kindly advise if there is a recommendation or solution for the log below.

       

      Version:

       

      Warning log

      16:27:28,962 WARN [org.jgroups.protocols.UDP] (ServerService Thread Pool -- 66) JGRP000014: the send buffer of socket DatagramSocket was set to 640KB, but the OS only allocated 212.99KB. This might lead to performance problems. Please set your max send buffer in the OS correctly (e.g. net.core.wmem_max on Linux)

      16:27:28,963 WARN  [org.jgroups.protocols.UDP] (ServerService Thread Pool -- 66) JGRP000014: the receive buffer of socket DatagramSocket was set to 20MB, but the OS only allocated 212.99KB. This might lead to performance problems. Please set your max receive buffer in the OS correctly (e.g. net.core.rmem_max on Linux)

      16:27:28,964 WARN [org.jgroups.protocols.UDP] (ServerService Thread Pool -- 66) JGRP000014: the send buffer of socket MulticastSocket was set to 640KB, but the OS only allocated 212.99KB. This might lead to performance problems. Please set your max send buffer in the OS correctly (e.g. net.core.wmem_max on Linux)

      16:27:28,965 WARN [org.jgroups.protocols.UDP] (ServerService Thread Pool -- 66) JGRP000014: the receive buffer of socket MulticastSocket was set to 25MB, but the OS only allocated 212.99KB. This might lead to performance problems. Please set your max receive buffer in the OS correctly (e.g. net.core.rmem_max on Linux)

       

      Workaround configuration setting

       

      Allow a 25MB UDP receive buffer for JGroups

      net.core.rmem_max = 26214400

      # Allow a 1MB UDP send buffer for JGroups

      net.core.wmem_max = 1048576

       

      Thank You