1 Reply Latest reply on Jun 23, 2017 5:27 AM by Rajeev Shukla

    Error deploying application on JBoss 6.4 EAP

    Rajeev Shukla Newbie

      I am trying to deploy an application war file. I keep getting the following error in the server log:

       

      Application startup failed: org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'myApp': Invocation of init method failed; nested exception is java.lang.NoClassDefFoundError: com/sun/nio/file/ExtendedWatchEventModifier

       

      I tried looking for a solution and found the answer at NoClassDefFoundError in JBoss AS7 closest to my issue. The solution suggests the following:

       

      It seems to me that Jboss modules does not load everything from rt.jar (maybe this is a result of the new classloading model).

      There is a modue named "sun.jdk" that depdends on module "system". Here are defined all packages jboss loads from rt.jar.

      I think that if you want extra packages, such as javax/annotation/processing, you have to add them in sun/jdk/main/module.xml.

       

      I tried adding the extra packages but it did not resolve the issue. I noticed that the module.xml that this gentleman has presented and the one that I have have different structures.

       

      Has anyone come across similar issue. What is the resolution for the same.

       

      Thanks,

       

      Rajeev