1 Reply Latest reply on Nov 30, 2017 3:31 AM by Wolf-Dieter Fink

    Does JBOSS AS 7.1.x still support EJB2.0?

    Eric Zhao Newbie

      Hello,

       

      I am trying to migrate the existing JBOSS AS 6.1.0 Final Version to JBOSS AS 7.1.3,  since jboss AS 6.1.0 Final use EJB2.0 in my application, my question is does JBOSS AS 7.1.3 still support EJB2.0?  any changes need to be done beside the class loading?

       

      Thanks in advance for any reply.

       

      Best Regards,

      Eric.

        • 1. Re: Does JBOSS AS 7.1.x still support EJB2.0?
          Wolf-Dieter Fink Master

          Yes, AS7.1 still include EJB2.0 support.

          But it is a complete redesign and some of the optimizations are not available, especially for EntityBeans using CMP!

           

          A few enhancements were made for EAP6 which is the Enterprise version based on AS7.x

           

          Since Wildfly 10 the support for EJB2.x EntityBeans is removed and the deploy will show an error if you try to deploy such Beans.

          This is because the EJB3.2 specification marked EntityBeans as optional because it is a 10 year old approach.

          Note: EJB2.0 SessionBeans are still allowed, but I recommend to use EJB3 implementation and if really necesarry use the legacy EJB2.x interfaces if you need to run EJB2.x clients. But you should aware that this is even more difficult and you need to change the client anyway.