4 Replies Latest reply on Jul 24, 2017 12:16 PM by James Perkins

    Log entries in EAP 7 do not show the module and line number correctly

    Eric Hardesty Newbie

      I am converting from EAP 6.4 and EAP 7 but am having issues with log entries.  The module and line number are not correct, they are always module(log) & linenumber(134) for every log entry.

       

      Is this a bug or do I need to specify something else to include the correct location in each log entry?

       

      Eric

       

      Here is my configuration:

                  <periodic-rotating-file-handler name="LTP" autoflush="true">

                      <formatter>

                          <pattern-formatter pattern="%d{HH:mm:ss,SSS} %-5p [%c.%M.%L] (%t) %s%E%n"/>

                      </formatter>

                      <file relative-to="jboss.server.log.dir" path="ltp.log"/>

                      <suffix value=".yyyy-MM-dd"/>

                      <append value="true"/>

                  </periodic-rotating-file-handler>

                  <logger category="com.bull" use-parent-handlers="false">

                      <level name="DEBUG"/>

                      <handlers>

                          <handler name="LTP"/>

                      </handlers>

                  </logger>

       

      output from EAP 6.4:

      09:29:15,545 DEBUG [com.bull.opentp.rts.cobol.CobolRuntimeSupport.start.69] (ResourceAdapter.runtimeThread) ENTER

      09:29:15,546 DEBUG [com.bull.opentp.rts.cobol.CobolRuntimeSupport.start.83] (ResourceAdapter.runtimeThread) EXIT

       

      output from EAP 7

      14:21:53,622 DEBUG [com.bull.opentp.rts.cobol.CobolRuntimeSupport.log.134] (ResourceAdapter.runtimeThread) ENTER

      14:21:53,622 DEBUG [com.bull.opentp.rts.cobol.CobolRuntimeSupport.log.134] (ResourceAdapter.runtimeThread) EXIT