0 Replies Latest reply on Aug 1, 2017 5:34 AM by Abdul Awal Nayeem

    how to configure max-thread for maximum number of http request for wildfly 10 ?

    Abdul Awal Nayeem Newbie

      Hello, guys, I'm using wildfly for a few days. I'm facing a problem with wildfly, that is I want to increase or decrease executable threads inside wildfly server for testing and tuning purpose. First, I googled for the solution. Already I have tried 2 ways to meet my purpose. But, I don't know why it's not working.

       

      1st I tried this:

       

                       <host name="other-host" alias="CRUDinMaven2" default-web-module="CRUDinMaven2.war" disable-console-redirect="true">

                                <location name="/" handler="welcome-content">

                                    <filter-ref name="limit-connections"/>

                                    <filter-ref name="headers"/>

                                </location>

                      </host>

                      <request-limit name="limit-connections" max-concurrent-requests="20" queue-size="10"/>

                      <response-header name="headers" header-name="MY_HEADER-masum" header-value="someValue-masum"/>

       

      2nd way, many of them suggested this way, but I didn't find any visible change in JMeter test.

       

                      <subsystem xmlns="urn:jboss:domain:io:1.1">

                                    <worker name="default" io-threads="10" task-max-threads="10" stack-size="10"/>

                                    <buffer-pool name="default"/>

                      </subsystem>

                      <http-listener name="default" max-connections="8989" socket-binding="http" redirect-socket="https" enable-http2="true"/>

       

       

      Can anyone please tell me what am I doing wrong?

      Thanks in advance.