2 Replies Latest reply on Sep 27, 2017 3:29 AM by Aditya Neurgaonkar

    Issue with  lang-addon.xml jboss while using ZK components

    Aditya Neurgaonkar Newbie

      I am deploying WAR file in JBoss 6.4.0 EAP, on deploying I am getting following error:

       

       

      17:07:57,168 SEVERE [org.zkoss] (ServerService Thread Pool -- 63) File not found: /WEB-INF/lang-addon.xml, at [SYS jndi:/default-host/MI42QA03A/WEB-INF/zk.xml line 13 col 17]

      17:07:57,773 WARNING [org.zkoss] (ServerService Thread Pool -- 63) Component eQtranscombobox ignored. Reason: extends a non-existent component eQcombobox.

      [SYS vfs:/data/MI/Jboss/jboss-eap-6.4_7.5_9095_9495/standalone/deployments/MI42QA03A.war/WEB-INF/lib/basiccomponents-4.2.jar/metainfo/zk/lang-addon.xml line 14 col 13]

      17:07:57,912 WARNING [org.zkoss] (ServerService Thread Pool -- 63) Component eQqueuecombobox ignored. Reason: extends a non-existent component eQcombobox.

      [SYS vfs:/data/MI/Jboss/jboss-eap-6.4_7.5_9095_9495/standalone/deployments/MI42QA03A.war/WEB-INF/lib/basiccomponents-4.2.jar/metainfo/zk/lang-addon.xml line 21 col 13]

      17:07:57,912 WARNING [org.zkoss] (ServerService Thread Pool -- 63) Component eQServerCombobox ignored. Reason: extends a non-existent component eQcombobox.

      [SYS vfs:/data/MI/Jboss/jboss-eap-6.4_7.5_9095_9495/standalone/deployments/MI42QA03A.war/WEB-INF/lib/basiccomponents-4.2.jar/metainfo/zk/lang-addon.xml line 28 col 13]

      17:07:57,915 WARNING [org.zkoss] (ServerService Thread Pool -- 63) Component eQgatewayCombobox ignored. Reason: extends a non-existent component eQcombobox.

      [SYS vfs:/data/MI/Jboss/jboss-eap-6.4_7.5_9095_9495/standalone/deployments/MI42QA03A.war/WEB-INF/lib/basiccomponents-4.2.jar/metainfo/zk/lang-addon.xml line 35 col 13]

       

       

      This error occurs in following environment:

      Server: JBoss EAP 6.4

      JDK: 1.8.0.121

      OS: RHEL 6.4

      DB: Oracle 12c (SSL)

       

       

       

       

      This error is not reproduced in any other environment.

       

       

      Please let me know the reason for this issue.