3 Replies Latest reply on Jul 9, 2008 4:04 AM by Heiko Rupp

    Operations Network 2.0-Inventory of a WAR within an EAR

    Gary J. Krasovic Jr. Newbie

      I'm having an issue where I can't seem to detect a WAR inside of an EAR for things like response time. Can someone shed some light on this for me? - other WAR's (the JMX console and the like) seem to be picked up fine, but the ones within the EAR's in the app server don't seem to want to inventory properly.

      - G

        • 1. Re: Operations Network 2.0-Inventory of a WAR within an EAR
          Heiko Rupp Master

          Hello,
          does the war archive show up in the inventory at all?
          If you go to the inventory tab of the ear file, does it show up as child resource?
          Did you deploy it as exploded ear/war or zipped?
          And what version of JbossAS is this?

          Thanks
          Heiko

          • 2. Re: Operations Network 2.0-Inventory of a WAR within an EAR
            Gary J. Krasovic Jr. Newbie

            Well, I had a meeting and I came back, and lo and behold the WAR's are there now... don't know what took it so long, but it seems to have picked them up.

            The next hurdle is to get the metrics working from them. I have the response time logs configured in the web.xml and the text files are there properly, but I don't see any response time info or any error info or anything else on the war monitoring screen.

            I realize these are rather vague questions, but I'm not really sure where to turn to as the documentation I've found is also rather vague and seems to indicate that things are just going to work (or assume that I know enough that the configuration should be obvious)

            I'm running the EAR's exploded (not zipped), and it's JBoss 3.2.7 and 3.2.8.

            Thanks for your assistance.

            - Gary

            • 3. Re: Operations Network 2.0-Inventory of a WAR within an EAR
              Heiko Rupp Master

              Gary,
              discovery is running 'recursively' down the resource tree. So it is possible that it was just happening while you were first looking at the resources. But glad that it is working.

              I understand your second paragraph that you are indeed seeing response time data logs being created, but you are not seeing the data in the GUI?

              Well, there are two places in the GUI to look at:

              - The inventory tab of the war in question: This needs to point at the file with the response time data
              - The configure subtab of the monitor tab of the war: here you need to enable the "HTTP Response Time" metric

              See https://docs.jbosson.redhat.com/confluence/display/JON2/Response+Times

              Hope this helps
              Heiko