1 Reply Latest reply on Oct 11, 2017 10:46 AM by Tomaz Cerar

    JBoss 4.2 to WildFly 10 upgrade

    Nupur priya Newbie

      Hi,

      We are trying to upgrade existing Application Server used in PCP (Prime Collaboration Provisioning).

      Current Version : JBoss EAP 4.2.0.GA_CP09

      Desired Version : WildFly 10

       

      The target application server requires lot of configuration changes. We did almost all the configuration changes and trying to deploy existing artifacts in WildFly 10.

      The deployment is not happening completely as we are getting some issues in the deployment of EJB artifacts where MDB (Message Driven Bean) is not getting deployed properly.

      We have implementation of EJB 2.0 right now and the MDB uses jms-ra (JMS Resource Adapter). Under WildFly 10, we tried to configure generic-jms-ra which is compatible with WildFly 10 and tried to deploy the same EJB artifact, but couldn't resolve the exceptions.

       

      In WildFly 10, we using standalone configuration only and whatever subsyem is required by PCP has been configured. All the jars and classes which were referred in older JBoss 4.2 has been configured as modules in WildFly 10 as the structure of class loading and classpath reference is changed considerable in WilFly 10.

       

      We have 2 WAR and 3 JAR artifacts that provides the complete application server functionality.

      Out of these we are now getting exceptions in deploying only 2 JAR artifacts and that too in only MDB used in them. Overall only 2 MDBs are implemented in PCP code base. So, the problem area is not big enough it seems.

      It could be that we have not configured the resource adapter properly as there is an exception related to that as well.

       

      Need your help in resolving these issues so we can upgrade to the latest application server. There is a vulnerability defect already opened for older version of JBoss and we need to migrate to newer version ASAP.

       

      Now the summary of exceptions is as follows:

       

      "{\"WFLYCTL0180: Services with missing/unavailable dependencies\" => [

          \"jboss.naming.context.java.comp.dfc.niceEjb.InitialServiceActionRequestMDB.ValidatorFactory is missing [jboss.naming.context.java.comp.dfc.niceEjb.InitialServiceActionRequestMDB]\",

          \"jboss.naming.context.java.comp.dfc.niceEjb.InitialServiceActionRequestMDB.Validator is missing [jboss.naming.context.java.comp.dfc.niceEjb.InitialServiceActionRequestMDB]\",

          \"jboss.naming.context.java.comp.dfc.niceEjb.InitialServiceActionRequestMDB.InAppClientContainer is missing [jboss.naming.context.java.comp.dfc.niceEjb.InitialServiceActionRequestMDB]\",

          \"jboss.deployment.subunit.\\\"dfc.ear\\\".\\\"dfc.war\\\".INSTALL is missing [jboss.deployment.subunit.\\\"dfc.ear\\\".\\\"niceEjb.jar\\\".deploymentCompleteService]\",

          \"jboss.deployment.subunit.\\\"dfc.ear\\\".\\\"commonEjb.jar\\\".component.ASyncActionExecutor.CREATE is missing [jboss.ra.generic-jms-ra]\",

          \"jboss.naming.context.java.comp.dfc.niceEjb.InitialServiceActionRequestMDB.InstanceName is missing [jboss.naming.context.java.comp.dfc.niceEjb.InitialServiceActionRequestMDB]\",

          \"jboss.deployment.unit.\\\"dfc.ear\\\".deploymentCompleteService is missing [jboss.deployment.subunit.\\\"dfc.ear\\\".\\\"niceEjb.jar\\\".deploymentCompleteService, jboss.deployment.subunit.\\\"dfc.ear\\\".\\\"dfc.war\\\".deploymentCompleteService]\"

       

      The structure of deployment folder is something like this:

      dfc.ear (directory)

        --- axis2.war (dir)

        --- dfc.war (dir)

        --- commonEJB.jar (dir)

        --- niceEjb.jar(dir)

        --- wfEjb.jar(dir)

        --- META-INF

       

      [root@pcp-java8 dfc.ear]# pwd

      /opt/cupm/sep/deploy/dfc.ear

      [root@pcp-java8 dfc.ear]# ls

      axis2.war commonEjb.jar dfc.war META-INF niceEjb.jar wfEjb.jar

       

      [root@pcp-java8 dfc.ear]# ls META-INF/

      application.xml weblogic-application.xml

       

      [root@pcp-java8 dfc.ear]# ls dfc.war/

      access_denied.jsp collablogout.xml im languages logout.xml not_found.jsp sample.jsp testCertHttp.jsp wf

      admin collablogout.xsl index.jsp lib logout.xsl oem shared testCert.jsp

      applications common ipt login_error.jsp navigate.jsp originals sitemap.xmap wap-registry

      blank.gif custom json logout.jsp nice reporting src WEB-INF

       

      [root@pcp-java8 dfc.ear]# ls commonEjb.jar/

      META-INF

      [root@pcp-java8 dfc.ear]# ls commonEjb.jar/META-INF/

      ejb-jar.xml ias-ejb-jar.xml jboss.xml weblogic-ejb-jar.xml

       

      [root@pcp-java8 dfc.ear]# ls niceEjb.jar/

      META-INF

      [root@pcp-java8 dfc.ear]# ls niceEjb.jar/META-INF/

      ejb-jar.xml weblogic-ejb-jar.xml

       

      [root@pcp-java8 dfc.ear]# ls wfEjb.jar/

      META-INF

      You have new mail in /var/spool/mail/root

      [root@pcp-java8 dfc.ear]# ls wfEjb.jar/META-INF/

      ejb-jar.xml jboss.xml weblogic-ejb-jar.xml

       

      Appreciate your response in resolving this important issue.