7 Replies Latest reply on Dec 3, 2017 4:56 PM by Martin Choma

    Attribute 'enabled-cipher-suites' in the resource at address '/subsystem=undertow/server=default-server/https-listener=https' is deprecated

    gir489 Novice

      I ran the converter for Wildfly 10.1 to Wildfly 11 seen in this thread: wildfly-server-migration Invalid byte 1 of 1-byte UTF-8 sequence.

       

      It added a bunch of stuff to the XML for Elytron, but I still see the same deprecation warnings I was getting before without running the converter. I checked the migration documents mentioned here in the release notes: Migrate Legacy Security to Elytron Security - Latest WildFly Documentation - Project Documentation Editor but I don't see anything pertaining to enabled-cipher-suites, or what's being deprecated with them.

       

      Basically all I'm worried about is when Wildfly 12 comes out, and you do the full force switch to Elytron only, will my config still work? Is the config converter going to clean up the rest of those deprecated warnings for the 11 -> 12 converter?