3 Replies Latest reply on Dec 4, 2017 1:03 PM by Radoslav Husar

    Wildfly 11: issue with mod_cluster 1.2.6/Apache 2.2.15

    Inova Software Newbie

      Hi,

       

      I am making a migration to Wildfly 11 from WildflY 10.01 and I have a strange behaviour.

       

      I have a front Apache 2.2 with several virtualhosts. In those virtualhost I have several context  pointing to different servers (tomcat and wildfly) and a proxypass to the balancer.

       

      When I start a server of the cluster, trying to access a context outside the cluster results in a http 404. Like every requests were redirected to the cluster.

       

      apache configuration is working with Wildfly 10 but have a different behavior with Wildfly 11.

       

      Is there someone who experienced the same issue?

       

      Thanks

       

      Franck

        • 1. Re: Wildfly 11: issue with mod_cluster 1.2.6/Apache 2.2.15
          Radoslav Husar Master

          One thing that comes to mind is that since WildFly 11 mod_cluster will register the undertow paths with the proxy as well, which were previously ignored. So maybe you have the / location registred with the proxy but with no corresponding files to handle thus 404? If that's the case then just run

           

          [standalone@localhost:9990 /] /subsystem=undertow/server=default-server/host=default-host/location=\/:remove()

          {

              "outcome" => "success",

              "response-headers" => {

                  "operation-requires-reload" => true,

                  "process-state" => "reload-required"

              }

          }

          [standalone@localhost:9990 /] :reload

          {

              "outcome" => "success",

              "result" => undefined

          }

           

          if that doesn't help look at the mod_cluster-management console to see whether contexts registred match the expectations.

          • 2. Re: Wildfly 11: issue with mod_cluster 1.2.6/Apache 2.2.15
            Inova Software Newbie

            Hi,

             

            Finally I figure out this issue. I added the attribute: excluded-contexts="ROOT" and everything was working like in Wildfly 10.0.1 without changing my Apache configuration.

             

            ex:

            <mod-cluster-config advertise-socket="modcluster" proxies="httpd1 httpd2" advertise="false" excluded-contexts="ROOT" auto-enable-contexts="true" sticky-session="false" worker-timeout="2" ttl="10" connector="ajp">

             

            If you don't exclude the ROOT every ProxyPassMatch rule is ignored.

             

            From mod_cluster documentation:

             

            From the proxy's perspective requests to an undeployed web application are indistinguishable from a request for an non-existent resource, and will result in 404 errors

             

            Thanks

            • 3. Re: Wildfly 11: issue with mod_cluster 1.2.6/Apache 2.2.15
              Radoslav Husar Master

              Right, you can use excluded contexts too, but that root context is still deployed on WildFly. If you do not need it at all (e.g. from different balancer or accessed differently) you should remove it.