0 Replies Latest reply on Jan 5, 2018 12:40 PM by Gopi Mohan

    How to configure  2 domain with 2 ssl one deployment in wildly

    Gopi Mohan Newbie

      Hi

      Our application have 2 domain ( inhouse.com, inhousetest.com  ) have 2 ssl  configuration and one deployment only . previously our application run on Jboss 7 it was working fine,  but we moved to wildfly 10  application not working , it show only wildfly home page only below I have mention the standalone  configuration .

       

      One domain inhouse.com only working inhousetest.com not working could you please suggest how to make it.

       

      <management>

              <security-realms>

                  <security-realm name="SslRealm">

                      <server-identities>

                          <ssl>

                              <keystore path="/usr/local/ssl/keyinhouse" keystore-password="test!" key-password="test!" generate-self-signed-certificate-host="inhouse.com"/>

                          </ssl>

                      </server-identities>

                      <authentication>

                          <local default-user="$local" allowed-users="*" skip-group-loading="true"/>

                          <properties path="application-users.properties" relative-to="jboss.server.config.dir"/>

                      </authentication>

                      <authorization>

                          <properties path="application-roles.properties" relative-to="jboss.server.config.dir"/>

                      </authorization>

                  </security-realm>

                  <security-realm name="SslRealmInhouse">

                      <server-identities>

                          <ssl>

                              <keystore path="/usr/local/ssl/inhouse/keyinhousetest" keystore-password="test!test" key-password="test!test"" generate-self-signed-certificate-host= inhousetest.com"/>

                          </ssl>

                      </server-identities>

                      <authentication>

                          <local default-user="$local" allowed-users="*" skip-group-loading="true"/>

                          <properties path="application-users.properties" relative-to="jboss.server.config.dir"/>

                      </authentication>

                      <authorization>

                          <properties path="application-roles.properties" relative-to="jboss.server.config.dir"/>

                      </authorization>

                  </security-realm>

      </management>

              </security-realms>

       

      <subsystem xmlns="urn:jboss:domain:undertow:3.1">

                  <buffer-cache name="default"/>

                  <server name="default-server">

                      <http-listener name="default" socket-binding="http" redirect-socket="https" enable-http2="true"/>

                      <https-listener name="https" socket-binding="https" security-realm="SslRealm" enable-http2="true"/>

                      <host name="default-host" alias="inhouse.com">

                          <location name="/" handler="welcome-content"/>

                          <filter-ref name="server-header"/>

                          <filter-ref name="x-powered-by-header"/>

                      </host>

                  </server>

                  <server name="inhouse-server">

                    <http-listener name="inhouse-server" socket-binding="inhouse-http" redirect-socket="inhouse-https" enable-http2="true"/>

                      <https-listener name="inhouse-https" socket-binding="inhouse-https" security-realm="SslRealmInhouse" enable-http2="true"/>

        <host name="default-host_inhouse" alias="inhousetest.com">

                          <location name="/" handler="welcome-content"/>

                          <filter-ref name="server-header"/>

                          <filter-ref name="x-powered-by-header"/>

        </host>

       

      <interfaces>

              <interface name="management">

                  <inet-address value="${jboss.bind.address.management:192.148.115.5}"/>

              </interface>

              <interface name="public">

                  <inet-address value="${jboss.bind.address:192.148.115.5}"/>

              </interface>

              <interface name="inhousetest">

                  <inet-address value="${jboss.bind.address:192.148.115.6}"/>

              </interface>

          </interfaces>

       

       

          <socket-binding-group name="standard-sockets" default-interface="public" port-offset="${jboss.socket.binding.port-offset:0}">

              <socket-binding name="management-http" interface="management" port="${jboss.management.http.port:9990}"/>

              <socket-binding name="management-https" interface="management" port="${jboss.management.https.port:9993}"/>

              <socket-binding name="inhouse-http" interface="inhouse" port="${jboss.http.port:80}"/>

              <socket-binding name="inhouse-https" interface="inhouse" port="${jboss.https.port:443}"/>

              <socket-binding name="ajp" port="${jboss.ajp.port:8009}"/>

              <socket-binding name="http" port="${jboss.http.port:80}"/>

              <socket-binding name="https" port="${jboss.https.port:443}"/>

              <socket-binding name="txn-recovery-environment" port="4712"/>

              <socket-binding name="txn-status-manager" port="4713"/>

              <outbound-socket-binding name="mail-smtp">

                  <remote-destination host="localhost" port="25"/>

              </outbound-socket-binding>

       

      Thanks

      Gopi