1 Reply Latest reply on Jan 18, 2018 10:12 AM by Amit Nijhawan

    Seems Wildfly deploy the module but doesnt show and cant use

    Gergely Toth Newbie

      I have a Wildfly 9.0.2.Final on Ubuntu 16.04. When I would deploy the application's login module its success.

       

      [DEBUG] (f) batch = true
      [DEBUG] (f) commands = [/subsystem=ee:write-attribute(name="global-modules",value=[{"name" => "com.mycompany.login","slot" => "main"}])]
      [DEBUG] (f) executeCommands = org.wildfly.plugin.cli.Commands@66b59b7d
      [DEBUG] (f) hostname = myproject.westus.cloudapp.azure.com
      [DEBUG] (f) password = testpassword
      [DEBUG] (f) port = 9990
      [DEBUG] (f) settings = org.apache.maven.execution.SettingsAdapter@4437ac07
      [DEBUG] (f) username = jenkins
      [DEBUG] -- end configuration --
      [DEBUG] Executing commands
      [DEBUG] Getting credentials from the POM Authenticating against security realm: ManagementRealm
      [INFO]
      [INFO] BUILD SUCCESS
      [INFO] ------------------------------------------------------------------------
      [INFO] Total time: 6.603 s
      [INFO] Finished at: 2018-01-17T08:01:21-05:00
      [INFO] Final Memory: 24M/250M

       

      Unfortunately when I would deploy the postgresql component I get the following error.

       

      2018-01-17 12:53:13,755 INFO [org.jboss.as.server.deployment] (MSC service thread 1-2) WFLYSRV0028: Stopped deployment postgresql.jar (runtime-name: postgresql.jar) in 5ms
      2018-01-17 12:53:13,756 ERROR [org.jboss.as.server] (management-handler-thread - 2) WFLYSRV0021: Deploy of deployment "postgresql.jar" was rolled back with the following failure message:
      {"WFLYCTL0080: Failed services" => {"jboss.module.service.\"deployment.postgresql.jar\".main" => "org.jboss.msc.service.StartException in service jboss.module.service.\"deployment.postgresql.jar\".main: WFLYSRV0179: Failed to load module: deployment.postgresql.jar:main
      Caused by: org.jboss.modules.ModuleNotFoundException: com.mycompany.login:main"}}

       

      In the deployments or the deployments/tmp folder I can not find anything. I changed the log level and I don't know where I move forward. Any suggestion?