0 Replies Latest reply on Jan 23, 2018 6:15 AM by Mylos Kathos

    Using Arquillian Universe with Arquillian Drone

    Mylos Kathos Master

      Hi all,

      I have an Arquillian Drone project which is essentially based on this example project: arquillian-examples/arquillian-drone-tutorial at master · arquillian/arquillian-examples · GitHub

      I have updated the pom.xml file to include Arquillian Universe as follows:

       

       

       

      <?xml version="1.0" encoding="UTF-8"?>
      <project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="         http://maven.apache.org/POM/4.0.0         http://maven.apache.org/xsd/maven-4.0.0.xsd">
         <modelVersion>4.0.0</modelVersion>
         <groupId>org.jboss.arquillian.examples</groupId>
         <artifactId>arquillian-drone-tutorial</artifactId>
         <version>1.0.0-SNAPSHOT</version>
         <packaging>jar</packaging>
         <name>arquillian-drone-tutorial</name>
         <url>http://arquillian.org/guides/functional_testing_using_drone/</url>
         <properties>
            <project.build.sourceEncoding>UTF-8</project.build.sourceEncoding>
            <version.arquillian_universe>1.1.13.5</version.arquillian_universe>
         </properties>
         
         <dependencyManagement>
            <dependencies>
               <dependency>
                  <groupId>org.arquillian</groupId>
                  <artifactId>arquillian-universe</artifactId>
                  <version>${version.arquillian_universe}</version>
                  <scope>import</scope>
                  <type>pom</type>
               </dependency>
            </dependencies>
         </dependencyManagement>
         <dependencies>
            <dependency>
               <groupId>org.arquillian.universe</groupId>
               <artifactId>arquillian-drone</artifactId>
               <scope>test</scope>
               <type>pom</type>
            </dependency>
            <dependency>
               <groupId>org.arquillian.universe</groupId>
               <artifactId>arquillian-junit</artifactId>
               <scope>test</scope>
               <type>pom</type>
            </dependency>
            <dependency>
               <groupId>org.jboss.arquillian.junit</groupId>
               <artifactId>arquillian-junit-container</artifactId>
               <scope>test</scope>
            </dependency>
            <dependency>
               <groupId>org.jboss.arquillian.extension</groupId>
               <artifactId>arquillian-drone-impl</artifactId>
               <scope>test</scope>
            </dependency>
            <dependency>
               <groupId>org.jboss.arquillian.extension</groupId>
               <artifactId>arquillian-drone-selenium</artifactId>
               <scope>test</scope>
            </dependency>
            <dependency>
               <groupId>org.jboss.arquillian.extension</groupId>
               <artifactId>arquillian-drone-selenium-server</artifactId>
               <scope>test</scope>
            </dependency>
            <dependency>
               <groupId>org.seleniumhq.selenium</groupId>
               <artifactId>selenium-java</artifactId>
               <scope>test</scope>
            </dependency>
            <dependency>
               <groupId>org.seleniumhq.selenium</groupId>
               <artifactId>selenium-server</artifactId>
               <scope>test</scope>
               <exclusions>
                  <exclusion>
                     <groupId>org.mortbay.jetty</groupId>
                     <artifactId>servlet-api-2.5</artifactId>
                  </exclusion>
               </exclusions>
            </dependency>
            <dependency>
               <groupId>org.slf4j</groupId>
               <artifactId>slf4j-simple</artifactId>
               <version>1.6.4</version>
               <scope>test</scope>
            </dependency>
         </dependencies>
        <!-- Profiles and builds commented -->
      </project>
      

      However it appears that all related dependencies of arquillian-drone and selenium cannot be retrieved when using the Arquillian Universe pom.xml:

       

      [ERROR] 'dependencies.dependency.version' for org.jboss.arquillian.extension:arquillian-drone-impl:jar is missing. @ line 71, column 21
      [ERROR] 'dependencies.dependency.version' for org.jboss.arquillian.extension:arquillian-drone-selenium:jar is missing. @ line 76, column 21
      [ERROR] 'dependencies.dependency.version' for org.jboss.arquillian.extension:arquillian-drone-selenium-server:jar is missing. @ line 81, column 21
      [ERROR] 'dependencies.dependency.version' for org.seleniumhq.selenium:selenium-java:jar is missing. @ line 86, column 21
      [ERROR] 'dependencies.dependency.version' for org.seleniumhq.selenium:selenium-server:jar is missing. @ line 91, column 21

       

      Can you help me to find out how to fix this in the pom.xml ?

      Thanks