3 Replies Latest reply on Feb 4, 2018 8:29 AM by Arkady Zelekman

    Wildfly 11: disable activemq authentication

    Arkady Zelekman Newbie

      Hi,

       

      I am trying to disable activemq authentication as following in standalone-full.xml:

       

                      <security-domain name="other" cache-type="default">

                                ...

                              <login-module code="RealmDirect" flag="required">

                                ...

                                  <module-option name="unauthenticatedIdentity" value="guest"/>

                              </login-module>

                      </security-domain>

       

      When I starting server I am getting:

      ActiveMQSecurityException[errorType=SECURITY_EXCEPTION message=AMQ119032: User: null does not have permission='CREATE_NON_DURABLE_QUEUE' on address...

       

      How can I do it correctly ? (We really don't want use authentication).

       

      Thanks,

      Arkady

        • 1. Re: Wildfly 11: disable activemq authentication
          Arkady Zelekman Newbie

          These are my activemq definitions:

           

                  <subsystem xmlns="urn:jboss:domain:messaging-activemq:2.0">

                      <server name="default">

                          <security-setting name="#">

                              <role name="guest" send="true" consume="true" create-non-durable-queue="true" delete-non-durable-queue="true"/>

                          </security-setting>

                          <address-setting name="#" dead-letter-address="jms.queue.DLQ" expiry-address="jms.queue.ExpiryQueue" max-size-bytes="10485760" page-size-bytes="2097152" message-counter-history-day-limit="10"/>

                          <http-connector name="http-connector" socket-binding="http" endpoint="http-acceptor"/>

                          <http-connector name="http-connector-throughput" socket-binding="http" endpoint="http-acceptor-throughput">

                              <param name="batch-delay" value="50"/>

                          </http-connector>

                          <in-vm-connector name="in-vm" server-id="0">

                              <param name="buffer-pooling" value="false"/>

                          </in-vm-connector>

                          <http-acceptor name="http-acceptor" http-listener="default"/>

                          <http-acceptor name="http-acceptor-throughput" http-listener="default">

                              <param name="batch-delay" value="50"/>

                              <param name="direct-deliver" value="false"/>

                          </http-acceptor>

                          <in-vm-acceptor name="in-vm" server-id="0">

                              <param name="buffer-pooling" value="false"/>

                          </in-vm-acceptor>

                          <jms-queue name="ExpiryQueue" entries="java:/jms/queue/ExpiryQueue"/>

                          <jms-queue name="DLQ" entries="java:/jms/queue/DLQ"/>

                          <jms-topic name="NMSTopic" entries="topic/NMSTopic java:jboss/exported/topic/NMSTopic"/>

                          <connection-factory name="InVmConnectionFactory" entries="java:/ConnectionFactory" connectors="in-vm"/>

                          <connection-factory name="RemoteConnectionFactory" entries="java:jboss/exported/jms/ConnectionFactory jms/ConnectionFactory" connectors="http-connector"/>

                          <pooled-connection-factory name="activemq-ra" entries="java:/JmsXA java:jboss/DefaultJMSConnectionFactory" connectors="in-vm" transaction="xa"/>

                      </server>

                  </subsystem>

          • 2. Re: Wildfly 11: disable activemq authentication
            Greg Jewell Novice

            I'm guessing that you disable security the same way as in WF10, since they both use ActiveMQ.

             

            How to disable jms security in wildfy 10