5 Replies Latest reply on Feb 4, 2018 1:32 PM by Archana Kumari

    Deployment failing because of error Caused by: javax.persistence.PersistenceException: WFLYJPA0057: PersistenceProvider 'org.eclipse.persistence.jpa.PersistenceProvider' not found in Jboss EAP 7.0.9

    Archana Kumari Newbie

      I am trying to deploy the war in JBoss EAP 7.0.9,but I am getting error while deploying Caused by: javax.persistence.PersistenceException: WFLYJPA0057: PersistenceProvider 'org.eclipse.persistence.jpa.PersistenceProvider' not found.

       

      As suggested by many forums I have eclipselink in my modules folder.

      My modules.xml looks like below:-

       

      <module xmlns="urn:jboss:module:1.3" name="org.eclipse.persistence">

          <properties>

              <property name="jboss.api" value="unsupported"/>

          </properties>

          <resources>

              <resource-root path="jipijapa-eclipselink-7.0.0.GA-redhat-2.jar"/>

             <resource-root path="eclipselink-2.5.2.jar">

            <filter>

                <exclude path="javax/**" />

           </filter>

              </resource-root>

          </resources>

          <dependencies>

              <module name="asm.asm"/>

              <module name="javax.api"/>

              <module name="javax.annotation.api"/>

              <module name="javax.enterprise.api"/>

              <module name="javax.persistence.api"/>

              <module name="javax.transaction.api"/>

              <module name="javax.validation.api"/>

              <module name="javax.xml.bind.api"/>

              <module name="org.antlr"/>

              <module name="org.dom4j"/>

              <module name="org.javassist"/>

              <module name="org.jboss.as.jpa.spi"/>

              <module name="org.jboss.logging"/>

              <module name="org.jboss.vfs"/>

          </dependencies>

      </module>

       

      My persistemce.xml looks like below:-

       

      <provider>org.eclipse.persistence.jpa.PersistenceProvider</provider>

      <jta-data-source>jdbc/topodb</jta-data-source>

      <exclude-unlisted-classes>false</exclude-unlisted-classes>

      <shared-cache-mode>NONE</shared-cache-mode>

       

       

      My entry for eclipselink in standalone.xml looks like this:-

       

          <system-properties>

              <property name="eclipselink.archive.factory" value="org.jipijapa.eclipselink.JBossArchiveFactoryImpl"/>

          </system-properties>

       

       

      My full stacktrace exception is below:-

       

      09:23:37,348 INFO  [org.jboss.as.jpa] (MSC service thread 1-1) WFLYJPA0002: Read persistence.xml for com.amadeus.topodb

      09:23:37,443 ERROR [org.jboss.msc.service.fail] (MSC service thread 1-8) MSC000001: Failed to start service jboss.deployment.unit."topodb.war".FIRST_MODULE_USE: org.jboss.msc.service.StartException in service jboss.deployment.unit."topodb.war".FIRST_MODULE_USE: WFLYSRV0153: Failed to process phase FIRST_MODULE_USE of deployment "topodb.war"

              at org.jboss.as.server.deployment.DeploymentUnitPhaseService.start(DeploymentUnitPhaseService.java:172)

              at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:2032)

              at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1955)

              at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)

              at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)

              at java.lang.Thread.run(Thread.java:745)

      Caused by: javax.persistence.PersistenceException: WFLYJPA0057: PersistenceProvider 'org.eclipse.persistence.jpa.PersistenceProvider' not found

              at org.jboss.as.jpa.processor.PersistenceUnitServiceHandler.lookupProvider(PersistenceUnitServiceHandler.java:1009)

              at org.jboss.as.jpa.processor.PersistenceUnitServiceHandler.addPuService(PersistenceUnitServiceHandler.java:270)

              at org.jboss.as.jpa.processor.PersistenceUnitServiceHandler.handleWarDeployment(PersistenceUnitServiceHandler.java:203)

              at org.jboss.as.jpa.processor.PersistenceUnitServiceHandler.deploy(PersistenceUnitServiceHandler.java:131)

              at org.jboss.as.jpa.processor.PersistenceBeginInstallProcessor.deploy(PersistenceBeginInstallProcessor.java:52)

              at org.jboss.as.server.deployment.DeploymentUnitPhaseService.start(DeploymentUnitPhaseService.java:165)

              ... 5 more

       

       

      09:23:37,444 ERROR [org.jboss.as.controller.management-operation] (DeploymentScanner-threads - 2) WFLYCTL0013: Operation ("deploy") failed - address: ([("deployment" => "topodb.war")]) - failure description: {"WFLYCTL0080: Failed services" => {"jboss.deployment.unit.\"topodb.war\".FIRST_MODULE_USE" => "org.jboss.msc.service.StartException in service jboss.deployment.unit.\"topodb.war\".FIRST_MODULE_USE: WFLYSRV0153: Failed to process phase FIRST_MODULE_USE of deployment \"topodb.war\"

          Caused by: javax.persistence.PersistenceException: WFLYJPA0057: PersistenceProvider 'org.eclipse.persistence.jpa.PersistenceProvider' not found"}}

      09:23:37,473 INFO  [org.jboss.as.server] (DeploymentScanner-threads - 2) WFLYSRV0010: Deployed "topodb.war" (runtime-name : "topodb.war")

      09:23:37,474 INFO  [org.jboss.as.controller] (DeploymentScanner-threads - 2) WFLYCTL0183: Service status report

      WFLYCTL0186:   Services which failed to start:      service jboss.deployment.unit."topodb.war".FIRST_MODULE_USE: org.jboss.msc.service.StartException in service jboss.deployment.unit."topodb.war".FIRST_MODULE_USE: WFLYSRV0153: Failed to process phase FIRST_MODULE_USE of deployment "topodb.war"

       

       

       

      Can you please  help me know where I am going wrong?

       

      Thank you in advance