0 Replies Latest reply on Feb 14, 2018 7:34 AM by Nagaraju Chitimilla

    convert activemq-jms-ds.xml from JBoss4.2.3 to Wildfly11

    Nagaraju Chitimilla Newbie

      I have the following activemq-jms-ds.xml and i have converted most of the properties to wild-fly. Question is how can i map the following highlighted elements to wild-fly.

       

      activemq-jms-ds.xml

      <?xml version="1.0" encoding="UTF-8"?>

      <connection-factories>

          <!-- The ActiveMQ JMS provider loader -->

          <mbean code="org.jboss.jms.jndi.JMSProviderLoader"

          name=":service=JMSProviderLoader,name=ActiveMQjmsProvider">

             <attribute name="ProviderName">ActiveMQJMSProvider</attribute>

              <attribute name="ProviderAdapterClass">org.jboss.jms.jndi.JNDIProviderAdapter</attribute>

              <attribute name="FactoryRef">ConnectionFactory</attribute>

              <attribute name="QueueFactoryRef">QueueConnectionFactory</attribute>

              <attribute name="TopicFactoryRef">TopicConnectionFactory</attribute>

              <attribute name="Properties">

                  java.naming.security.principal=guest

                  java.naming.factory.initial=com.ca.jms.utils.ActiveMQJndiContextFactory

                  java.naming.provider.url=ssl://localhost:61616?socket.enabledProtocols=TLSv1.1,TLSv1.2

                 anonymous=true

                  trustAll=true

                  xa=true

                  queue.queue/DLQ=ActiveMQ.DLQ

                  queue.test.queue=test.queue

             </attribute>

          </mbean>

      <!-- use it when open jms connection -->

      <tx-connection-factory>

          <jndi-name>ActivemqJms</jndi-name>

          <use-java-context>false</use-java-context>

          <xa-transaction></xa-transaction>

          <rar-name>jms-ra.rar</rar-name>

          <connection-definition>org.jboss.resource.adapter.jms.JmsConnectionFactory</connection-definition>

          <config-property name="SessionDefaultType" type="java.lang.String">javax.jms.Queue</config-property>

          <config-property name="JmsProviderAdapterJNDI" type="java.lang.String">java:/ActiveMQJMSProvider</config-property>

          <max-pool-size>150</max-pool-size>

      <security-domain-and-application>ActivemqRealm</security-domain-and-application>

          <blocking-timeout-millis>32000</blocking-timeout-millis>

      </tx-connection-factory>

      </connection-factories>

       

       

      wildfly11:

       

      <subsystem xmlns="urn:jboss:domain:messaging-activemq:2.0">

                  <server name="default">

                      <security-setting name="#">

                          <role name="guest" send="true" consume="true" create-non-durable-queue="true" delete-non-durable-queue="true"/>

                      </security-setting>

                      <address-setting name="#" dead-letter-address="jms.queue.DLQ" expiry-address="jms.queue.ExpiryQueue" max-size-bytes="10485760" page-size-bytes="2097152" message-counter-history-day-limit="10"/>

                      <http-connector name="http-connector" socket-binding="http" endpoint="http-acceptor"/>

                      <http-connector name="http-connector-throughput" socket-binding="http" endpoint="http-acceptor-throughput">

                          <param name="batch-delay" value="50"/>

                      </http-connector>

                      <in-vm-connector name="in-vm" server-id="0">

                          <param name="buffer-pooling" value="false"/>

                      </in-vm-connector>

                      <http-acceptor name="http-acceptor" http-listener="default"/>

                      <http-acceptor name="http-acceptor-throughput" http-listener="default">

                          <param name="batch-delay" value="50"/>

                          <param name="direct-deliver" value="false"/>

                      </http-acceptor>

                      <in-vm-acceptor name="in-vm" server-id="0">

                          <param name="buffer-pooling" value="false"/>

                      </in-vm-acceptor>

       

       

                      <jms-queue name="ExpiryQueue" entries="java:/jms/queue/ExpiryQueue"/>

                      <jms-queue name="DLQ" entries="java:/jms/queue/DLQ"/>

       

                        <jms-queue name="test.queue" entries="test.queue java:jboss/exported/jms/test.queue"/>

       

      <connection-factory name="InVmConnectionFactory" entries="java:/ConnectionFactory" connectors="in-vm"/>

        <connection-factory name="RemoteConnectionFactory" entries="java:jboss/exported/jms/RemoteConnectionFactory" connectors="http-connector"/>

      <connection-factory name="wpConnectionFactory" entries="jms/wpConnectionFactory wpConnectionFactory java:jboss/exported/jms/wpConnectionFactory" connectors="http-connector"/>

       

       

                      <pooled-connection-factory name="jms-ra" entries="java:/ActivemqJms java:jboss/DefaultJMSConnectionFactory" connectors="in-vm" transaction="xa"/>

                  </server>

              </subsystem>

       

       

      <resource-adapter id="jms-ra.rar">

      <archive>

         jms-ra.rar

      </archive>

            <transaction-support>NoTransaction</transaction-support>

            <connection-definitions>

                     <connection-definition class-name="org.jboss.resource.adapter.jms.JmsConnectionFactory" jndi-name="java:/ActivemqJms" pool-name="ActivemqJms" use-ccm="true" enabled="true" use-java-context="true">

             <config-property name="JndiParameters">java.naming.security.principal=guest;java.naming.factory.initial=com.ca.jms.utils.ActiveMQJndiContextFactory;java.naming.provider.url=ssl://localhost:61616?socket.enabledProtocols=TLSv1.1,TLSv1.2</config-property>

        <pool> 

               <min-pool-size>1</min-pool-size> 

               <max-pool-size>150</max-pool-size>

      </pool>

      <timeout>

        <blocking-timeout-millis>32000</blocking-timeout-millis>

      </timeout>

      <security>

      <security-domain>ActivemqRealm</security-domain>

      </security>

      </connection-definition>

      </connection-definitions>

      </resource-adapter>