3 Replies Latest reply on Feb 15, 2018 9:19 AM by jaikiran pai

    JBoss AS 5.1 - HTTP stuck/unavailable

    Davide Cicuta Newbie



      Not sure this is a JBoss problem after all, but I'm facing the same behaviour on different machines (all Linux servers) and different environments, so I ask you.


      I have an application running inside JBoss, which listens for HTTP requests on port 8080, plus on other ports for other protocols. The servers for the other protocols are instantiated inside the application, but they are not directly managed by the AS. Load is usually quite heavy on all ports. Sometimes (really randomly) it happens that port 8080 gets stuck: If I do a telnet to the port, it connects, but full HTTP requests are not served (they seem to hang).

      The connections at the OS level seem always to be hanging as well. No matter how many connections on port 8080 (using netstat), their receive and send queues never change in size. All other connections work perfectly.

      I tried to thread-dump the JBoss process, but I didn't find any trace of deadlocks nor other problems (or so it seems, based on my level of competence).


      This behaviour seems completely random (on most machines it doesn't occur at all), the server can work for ages or get stuck after one day. I never tried to write HTTP requests on an open telnet connection because I just thought about it, so I'll probably do that the next time the lock occurs, but in the meantime does anyone have any idea as to what could be going on, or an indication on how to find the actual culprit?


      Thank you very much in advance!