2 Replies Latest reply on Feb 16, 2018 8:59 PM by Anup Dey

    How to configure jboss-ejb-client.properties for SSL

    John Sipher Newbie

      I'm trying to connect to an EJB running in WildFly 10.1.0.Final from a remote non-WildFly client. This works fine without SSL but I can't find the right combination of properties to get it to work with SSL. Also note that it works fine communicating from a remote WildFly instance, so I'm 99.9% sure I have the server side configured correctly.

       

      The most recent combination I've tried looks like this

      remote.connectionprovider.create.options.org.xnio.Options.SSL_ENABLED=true
      remote.connections=myejb
      remote.connection.myejb.host=server.domain.com
      remote.connection.myejb.port=8443
      remote.connection.myejb.connect.options.org.xnio.Options.SASL_POLICY_NOANONYMOUS=false
      remote.connection.myejb.username=ejbuser
      remote.connection.myejb.password=ejbuserpwd
      remote.connection.myejb.protocol=https-remoting
      remote.connection.myejb.connect.options.org.xnio.Options.SSL_STARTTLS=true
      remote.connection.myejb.connect.options.org.xnio.Options.SSL_PROTOCOL=TLSv1.2

       

      The working non-SSL version looks like this

      remote.connectionprovider.create.options.org.xnio.Options.SSL_ENABLED=false
      remote.connections=myejb
      remote.connection.myejb.host=server.domain.com
      remote.connection.myejb.port=8080
      remote.connection.myejb.connect.options.org.xnio.Options.SASL_POLICY_NOANONYMOUS=false
      remote.connection.myejb.username=ejbuser
      remote.connection.myejb.password=ejbuserpwd

       

      The provider URL used in the InitailContext is remote-https://server.domain.com:8443 for the SSL version and remote-http://server.domain.com:8080 for the working non-SSL version.

       

      The SSL invocations always fail with the ubiquitous "EJBCLIENT000025: No EJB receiver available..." exception.

       

      Thanks for your help