2 Replies Latest reply on Feb 20, 2018 1:25 AM by itays100

    Richfaces 3.3.3 doesn't support jQuery 1.9.1 after post back!

    itay sahar Newbie



      We have an application with jsf 1.2, richfaces 3.3.3, seam 2.1.2, this application was developed (most backend) but recently we have received

      frontend work with bootstrap 3 , jquery (required 1.9.1).


      I was able to combine the richfaces jquery version 1.3.2 with the jquery 1.9.1 (with the noconflict()) but this works only on first page load. Any button or ajax post back

      (richfaces, a4j) cause the version mixup again.


      For example: I have used jquery datepicker plugin (jquery 1.9.1), this fancy plugin stop working after clicking the button, the script is actually not available after

      partial rendering and also when printing (alert) the jquery version 1.3.2 showing (After the postback).


      I've spend too much time myself on this and start thinking stop/replace richfaces with something else (that can use jquery 1.9.1).


      Any idea how should I solve this annoying and blocking issue?



        • 1. Re: Richfaces 3.3.3 doesn't support jQuery 1.9.1 after post back!
          Michal Petrov Master

          Once you have both version on the page they should stay there, partial updates shouldn't affect them. But I don't know enough about how RF 3 handles it to tell you what's happening. That said, RF 3 is rather old, so when you're trying to combine with a new-ish framework you will run into trouble. Can you upgrade to RichFaces 4?

          • 2. Re: Richfaces 3.3.3 doesn't support jQuery 1.9.1 after post back!
            itays100 Newbie

            Hi Michal,


            I'm considering to upgrade the application yes. Richfaces 4 require jsf 2 and seam 3. So it means that I should be full migration, also

            Richfaces 4 uses jquery 1.6 so it won't help I guess.


            It looks like that I simply can't use Richfaces and a4j anywhere (have to remove the jars). Icefaces 3.3.3 uses jquery 1.9.1 but again I'll

            need to upgrade to jsf 2 and seam 3.


            It doesn't make sense to upgrade to seam 3 as this project is old and no longer supported. Is there any alternative you recommend

            to move into ? I am happy to full migration - completely different libraries but it have to java server technologies so I can utilized the existing business

            logic (because we put the responsive design as #1 priority).


            Here are examples of technologies we are currently using: jpa 1 (entitymanager), envers 1.1, hibernate 3, jboss seam 2.1.2, quartz 2.1, apache poi 3.9, jasper reports (We have jrxml files).