5 Replies Latest reply on May 1, 2018 2:49 PM by surendra Thummanagoti

    Jboss EAP 6.4 Proxy Issue

    Nikil Surukanti Newbie

      In Jboss EAP 6.4, I have configured the proxy server info to reach the third party client. But it's not honoring those properties and trying to reach the third partly client directly. How can I resolve this?

        • 1. Re: Jboss EAP 6.4 Proxy Issue
          Anup Dey Expert

          You can try configuring your proxy JVM-wide using system properties (http.proxyHost and http.proxyPort)

           

          To setup/configure HTTP proxy server on SAM you can make following changes

          ~~~

          # vi /etc/katello/katello.yml

          ~~~

          Search for following lines

          ~~~

          #  cdn_proxy:

          #    host: localhost

          #    port: 3128

          ~~~

          Uncomment these lines and set values as bellow

           

          ~~~

            cdn_proxy:

              host: http-proxy-fqdn

              port: port-number

          ~~~

          If HTTP proxy server need username / password then provide it in the same file.

           

          See the PROXY INSTALLATION GUIDE:

           

          https://access.redhat.com/documentation/en-us/red_hat_network_satellite/5.4/html-single/proxy_installation_guide/index

          • 2. Re: Jboss EAP 6.4 Proxy Issue
            surendra Thummanagoti Newbie

            Thanks for Response Anup Dey.

             

            Me and Nikil both are same team. Just i am giving some more input to what we did.

             

            Q:Jboss Application is routing to third party application "xyz" through Proxy layer. we setup Proxy settings in different ways but didn't work out.

             

            1.   Setup through Standalone.conf

            2.   Setup through Standalone.sh

            3.   Setup through Standalone-ha.xml file as System properties

             

            Every scenario call was ended up and shows in log as "open a connection to xyz" & Output of SOAP UI was Empty. I contact to proxy team they are not seeing any traffic through layer and call was bypassing proxy layer and routing to the xyz.

             

            Proxy Settings:

            -Dhttp.proxyHost=*****.com -Dhttp.proxyPort=0000 -Dhttp.nonProxyHosts=localhost|server ipaddress|*.xxxxxx.com -Dhttps.proxyHost=*****.com -Dhttps.proxyPort=0000 -Dhttps.nonProxyHosts=localhost|server ip address|*.****.com -Dhttps.proxyHosts=https://******.com -Dhttps.proxyPort=0000

             

            Thanks,

            Chary

            • 3. Re: Jboss EAP 6.4 Proxy Issue
              Anup Dey Expert

              In standalone.xml after </extensions>

               

              add the following

               

              <system-properties>

                  <property name="http.proxyHost" value="yourProxyIpAddress"/>

                  <property name="http.proxyPort" value="yourProxyPort"/>

                  <property name="http.nonProxyHosts" value="localhost"/> <!-- if you want to ignore localhost -->

              </system-properties>

               

              Also try to to add something like this to the startup script of jboss:

               

               

              rem Setup JBoss specific properties:

              set JAVA_OPTS=%JAVA_OPTS% -Dprogram.name=%PROGNAME%

              set JAVA_OPTS=-Daxis.enableListQuery=true -Dhttp.proxyHost="server.mydomain.ac.uk" -Dhttp.proxyPort="8080" -Dhttp.proxyUser="username" -Dhttp.proxyPassword="password" %JAVA_OPTS%

              set JBOSS_HOME=%DIRNAME%\..

              • 4. Re: Jboss EAP 6.4 Proxy Issue
                surendra Thummanagoti Newbie

                Thanks Anup Dey!

                 

                 

                I already tried with adding system Properties in Standalone-ha.xml file

                 

                 

                    </extensions>

                 

                 

                    <system-properties>

                        <property name="http.proxyHost" value="hostname.domain.net"/>

                        <property name="http.proxyPort" value="port"/>

                        <property name="https.proxyHost" value="hostname.domain.net"/>

                        <property name="https.proxyPort" value="port"/>

                        <property name="http.nonProxyHosts" value="*.domain.net|localhost"/>

                        <property name="https.nonProxyHosts" value="*.domain.net|localhost"/>

                    </system-properties>

                 

                 

                And i tried with adding JAVA_OPTS in Standalone.conf file but it didn't work out.

                 

                 

                    JAVA_OPTS="$JAVA_OPTS -Dhttp.proxyHost=hostname.domain.net -Dhttp.proxyPort=port -Dhttps.proxyHost=hostname.domain.net -Dhttps.proxyPort=port -Dhttp.nonProxyHosts=\*\.domain\.net\|\localhost -Dhttps.nonProxyHosts=\*\.domain\.net\|\localhost"

                 

                 

                And also i tried with Ip Address too -Dhttp.nonProxyHosts=\*\.domain\.net\|\localhost\|ipaddress\ -Dhttps.nonProxyHosts=\*\.domain\.net\|\localhost|ipaddress\"

                 

                 

                Thanks,

                Chary

                • 5. Re: Jboss EAP 6.4 Proxy Issue
                  surendra Thummanagoti Newbie

                  Thanks to every one! Issue was resolved.

                   

                  By Adding JAVA_OPTS in Standalone.conf file 

                   

                      JAVA_OPTS="$JAVA_OPTS -Dhttp.proxyHost=hostname.domain.net -Dhttp.proxyPort=port -Dhttps.proxyHost=hostname.domain.net -Dhttps.proxyPort=port -Dhttp.nonProxyHosts=\*\.domain\.net\|\localhost -Dhttps.nonProxyHosts=\*\.domain\.net\|\localhost"

                   

                  and we do some changes to web application where these proxy setting need to pick while request is routing to the proxy.

                   

                  Thanks,

                  Chary