1 Reply Latest reply on Mar 19, 2018 7:38 PM by Martin Miller

    Wildfly 12 and Java 9 - webservices not detected ?

    Martin Miller Newbie

      I have an ear with some ejbs and a webservice, and it works under Java 8 and Wildfly 12.

       

      I can deploy my ear compiled (some of my libs are java 9 modules now) under Java 9

      on Wildfly 12 (also running java 9), but it looks my webservice annotations are not being detected jaxws doesn't start.

       

      I will work on a minimal example tomorrow to see if I can reproduce the problem and post more info, in the mean time

      does anyone have an idea of the problem ?

       

      Update: the "same" ear compiled under Java 8 does work on WildFly12+java 9.