0 Replies Latest reply on Apr 2, 2018 1:16 PM by Manjusha Gole

    How to include myfaces JSf implementation in Wildfly 10.1.0

    Manjusha Gole Newbie

      Hi,

       

      Our Web apps use Myfaces. But the Wildfly 10.1 does not support myfaces as a default JSF implementation. We tried including myfaces 1.2.12 implementation as per the link : JSF Configuration - WildFly 10 - Project Documentation Editor

       

      We do see the following entry in our standalone.xml, when we add the new implementation using jboss-cli.sh  :

      <subsystem xmlns="urn:jboss:domain:jsf:1.0" default-jsf-impl-slot="myfaces-1.2.12"/>

       

      We have also included the following in our web.xml:

      <context-param>

        <param-name>org.jboss.jbossfaces.JSF_CONFIG_NAME</param-name>

        <param-value>myfaces-1.2.12</param-value>

      </context-param>

      But when we start the Widlfly instance, all our war failed to deploy with following error:

       

          \"WFLYCTL0080: Failed services\" => {\"jboss.deployment.unit.\\\"xxx.war\\\".DEPENDENCIES\" => \"org.jboss.msc.service.StartException in service jboss.deployment.unit.\\\"xxx.war\\\".DEPENDENCIES: WFLYSRV0153: Failed to process phase DEPENDENCIES of deployment \\\"xxx.war\\\"

          Caused by: org.jboss.as.server.deployment.DeploymentUnitProcessingException: WFLYJSF0014: Default JSF implementation slot 'myfaces-1.2.12' is invalid\"},

          \"WFLYCTL0412: Required services that are not installed:\" => [\"jboss.deployment.unit.\\\"xxx.war\\\".DEPENDENCIES\"],

       

      We even tried with myfaces 2.1.18 but the result is same, getting the same error.

       

      When we try to list the activated JSF implementations using jboss-cli.sh, it does not list myfaces implementations. Please note that we have followed the steps exactly as given in the Wildfly documentations and also confirmed that the respective myfaces folders are created under WILDFLY_HOME/modules/.../com/sun/jsf-impl, WILDFLY_HOME/modules/.../javax/faces/api and WILDFLY_HOME/modules/.../org/jboss/as/jsf-injection.

       

      Is there anything that we are missing? Is there any other way to change the default JSF implementation in Wildfly 10.1.0?

       

      Thanks.