0 Replies Latest reply on Apr 10, 2018 3:01 AM by m j raju

    How to resolve java.util.MissingResourceException: Can't find bundle for base name, in wildfly

    m j raju Newbie

      Hi, Following is the code getting into the mentioned exception, when running on Wildfly, the same was workign fine in weblogic. Please suggest if I am missing something.

      myProperties = ResourceBundle.getBundle("myconfig/ConfigDetails");

      Following are the ways I tried configuring the properties file.

      1) I have placed ConfigDetails.properties under wildfly-12.0.0.Final\myconfig folder. this did not work, as ResourceBundle looking for loaded file

      2) I have created followoing module.xml and placed under wildfly-12.0.0.Final\modules\system\layers\base\myconfig\main folder along with my ConfigDetials.properties file. then added myconfig as dependancy in my application manifest.mf. even this also did not help

      <module name="myconfig" xmlns="urn:jboss:module:1.5">

          <resources>

              <resource-root path="."/>

          </resources>

      </module>

      3) Placed the properties file under src\main\resources\myconfig folder in my applciation and built the ear. But this too did not work

      4) with all the options tried referring the name as ConfigDetails.properties as well, i.e ResourceBundle.getBundle("myconfig/ConfigDetails.properties"), but this too did not help.

      ending up with following exception

      (default task-1) java.util.MissingResourceException: Can't find bundle for base name myconfig/ConfigDetails, locale en_US

      at java.util.ResourceBundle.throwMissingResourceException(ResourceBundle.java:1564)

      (default task-1) at java.util.ResourceBundle.getBundleImpl(ResourceBundle.java:1387)

      at java.util.ResourceBundle.getBundle(ResourceBundle.java:773)