4 Replies Latest reply on Apr 18, 2018 4:33 AM by Daniel Munzinger

    Compatibility of Artemis versions in WildFly

    Daniel Munzinger Newbie

      Hi,

       

      I have the following scenario:

       

      Message broker:   Artemis 2.5.0

      Producer:         Standalone Client with Artemis 2.5.0 jms-client-all.jar

      Consumer:         MDB in Wildfly 12 (built-in Artemis 1.5.5-jboss-009)

       

      If messages are sent from the producer the consumer fails with the following exception:

       

      2018-04-11 14:30:56,243 ERROR [org.apache.activemq.artemis.ra] (Thread-3 (ActiveMQ-client-global-threads)) AMQ154004: Failed to deliver message: java.lang.IndexOutOfBoundsException

      at org.apache.activemq.artemis.core.buffers.impl.ChannelBufferWrapper.readSimpleStringInternal(ChannelBufferWrapper.java:93)

      at org.apache.activemq.artemis.core.buffers.impl.ChannelBufferWrapper.readNullableSimpleString(ChannelBufferWrapper.java:73)

      at org.apache.activemq.artemis.reader.TextMessageUtil.readBodyText(TextMessageUtil.java:37)

      at org.apache.activemq.artemis.jms.client.ActiveMQTextMessage.doBeforeReceive(ActiveMQTextMessage.java:112)

      at org.apache.activemq.artemis.ra.inflow.ActiveMQMessageHandler.onMessage(ActiveMQMessageHandler.java:295)

      at org.apache.activemq.artemis.core.client.impl.ClientConsumerImpl.callOnMessage(ClientConsumerImpl.java:1001)

      at org.apache.activemq.artemis.core.client.impl.ClientConsumerImpl.access$400(ClientConsumerImpl.java:49)

      at org.apache.activemq.artemis.core.client.impl.ClientConsumerImpl$Runner.run(ClientConsumerImpl.java:1124)

      at org.apache.activemq.artemis.utils.OrderedExecutorFactory$OrderedExecutor$ExecutorTask.run(OrderedExecutorFactory.java:122)

      at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)

      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)

      at java.lang.Thread.run(Thread.java:748)

       

      If the producer sends with an 1.5.x client.jar everything works fine.

       

      Is this a wanted/known behavior or is this a bug!? A Google search didn't yield much about this topic.

       

      Thanks in advance,

       

      Daniel