2 Replies Latest reply on May 9, 2018 2:25 AM by C T

    Wildfly BOM missing dependency information

    C T Newbie

      Hi,

       

      For our projects with Wildfly we use the maven Wildfly BOM for dependency management.

      Now I want to start upgrading some of our projects from Wildfly 10.1.0.Final to 12.0.0.Final.

       

      After upgrading to the new 12.0.0.Final BOM the build produces some warnings and then fails.

      The output of the maven build:

      [INFO] Scanning for projects...

      [INFO]                                                                        

      [INFO] ------------------------------------------------------------------------

      [INFO] Building myproject 1.0-SNAPSHOT

      [INFO] ------------------------------------------------------------------------

      [WARNING] The POM for org.jboss.security:jboss-negotiation-extras:jar:${version.org.jboss.security.negotiation} is missing, no dependency information available

      [WARNING] The POM for org.jboss.security:jboss-negotiation-spnego:jar:${version.org.jboss.security.negotiation} is missing, no dependency information available

      [INFO] ------------------------------------------------------------------------

      [INFO] BUILD FAILURE

      [INFO] ------------------------------------------------------------------------

      [INFO] Total time: 2.328 s

      [INFO] Finished at: 2018-05-08T10:07:28+02:00

      [INFO] Final Memory: 19M/307M

      [INFO] ------------------------------------------------------------------------

      [ERROR] Failed to execute goal on project myproject: Could not resolve dependencies for project mygroupid:myproject:war:1.0-SNAPSHOT: The following artifacts could not be resolved: org.jboss.security:jboss-negotiation-extras:jar:${version.org.jboss.security.negotiation}, org.jboss.security:jboss-negotiation-spnego:jar:${version.org.jboss.security.negotiation}: Failure to find org.jboss.security:jboss-negotiation-extras:jar:${version.org.jboss.security.negotiation} in https://repo.maven.apache.org/maven2 was cached in the local repository, resolution will not be reattempted until the update interval of central has elapsed or updates are forced -> [Help 1]

       

      When I take a closer look at the 12.0.0.Final BOM the version for the org.jboss.security dependencies seems to be missing. Only the property placeholder "${version.org.jboss.security.negotiation}" can be found.

      Is this intentionally missing?

        • 1. Re: Wildfly BOM missing dependency information
          Tomaz Cerar Master

          WildFly 12 moved to elytron as main security framework and as such some of old dependencies are no longer used in the server.

          The negotiation-* stuff is one of them.

           

          It is correct that it is no longer in bom, but the property being left in is just and oversight.

          • 2. Re: Wildfly BOM missing dependency information
            C T Newbie

            Hi Tomaz, thank you for your reply.

             

            Do you think it is justified to submit a JIRA bugreport for this? So that the old dependencies will be removed from the BOM.

             

            As a workaround, I added the missing dependencies information to my project pom so the build will succeed.

            For others running into the same problem, this is what I added to my project pom:

             

            <project>

                .....

                <properties>

                    .....

                    <version.org.jboss.security.negotiation>3.0.4.Final</version.org.jboss.security.negotiation>

                    .....

                </properties>

             

                <dependencyManagement>

                    <dependencies>

                        .....

                        <dependency>

                            <groupId>org.jboss.security</groupId>

                            <artifactId>jboss-negotiation-common</artifactId>

                            <version>${version.org.jboss.security.negotiation}</version>

                            <scope>provided</scope>

                        </dependency>

                        <dependency>

                            <groupId>org.jboss.security</groupId>

                            <artifactId>jboss-negotiation-extras</artifactId>

                            <version>${version.org.jboss.security.negotiation}</version>

                            <scope>provided</scope>

                        </dependency>

                        <dependency>

                            <groupId>org.jboss.security</groupId>

                            <artifactId>jboss-negotiation-ntlm</artifactId>

                            <version>${version.org.jboss.security.negotiation}</version>

                            <scope>provided</scope>

                        </dependency>

                        <dependency>

                            <groupId>org.jboss.security</groupId>

                            <artifactId>jboss-negotiation-spnego</artifactId>

                            <version>${version.org.jboss.security.negotiation}</version>

                            <scope>provided</scope>

                        </dependency>

                        .....

                    </dependencies>

                </dependencyManagement>

                .......

            </project>