0 Replies Latest reply on May 22, 2018 4:28 AM by Akinwale Agbaje

    Temporary Queue not responding in Jboss EAP 7

    Akinwale Agbaje Newbie

      Hi All,

       

      I'm pretty new to Jboss. At where I work, we use Oracle's Weblogic 12c, and I've been tasked with learning all about Jboss EAP 7 to see if it's a better fit. What I'm trying to do is replicate stuff I've been able to do on Weblogic on Jboss EAP 7, but I'm having a pretty difficult time doing that.

       

      Right now, it's JMS, and currently while I've been able to deploy (finally) an MDB, anytime I send a message from my client to the MDB, the MDB is supposed to respond with some message via a temporary queue. Instead, what happens is, the MDB receives the message, but then an error is thrown on the server logs, saying:

       

      javax.jms.InvalidDestinationException: Not an ActiveMQ Artemis Destination:ActiveMQTemporaryQueue[4557fdb1-72ec-4139-9817-989ecc46c7a8]

              at org.apache.activemq.artemis.jms.client.ActiveMQSession.createProducer(ActiveMQSession.java:293)

              at org.jboss.server.ServerSide.respondToSenderPositive(ServerSide.java:121)

              at org.jboss.server.ServerSide.onMessage(ServerSide.java:67)

              at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

       

      I've looked around the internet but I can't seem to find anything on this particular problem. Perhaps there's something else I should configure on the server, I don't.

       

      I've gone through the entirety of the official Red Hat Jboss Message configuration: Part I. About Messaging and JBoss EAP 7 - Red Hat Customer Portal , yet nothing pops up that can help resolve my problem. My codes look exactly like what you'll find here: Chapter 14. Temporary Queues and Runtime Queues - Red Hat Customer Portal

       

      I was hoping any one of you guys here could help.

       

      Thanks.