4 Replies Latest reply on Jun 12, 2018 8:23 AM by Galder Zamarreño

    Infinispan 9.2.3 bom reference infinispan-remote 9.2.3.Final does not exist

    Andreas Öh Newbie

      Hi,

      I might have got this messed up in my maven pom's, but I am trying to build an infinispan client which uses the hotrod client and are having problems importing the correct version in my maven project.

       

      The inifinispan server I am running is the docker image, infinispan-server:9.2.3.Final. In my parent maven project I have added the following:

      ....

      <properties>

          <version.org.infinispan>9.2.3.Final</version.org.infinispan>

      </properties>

      ....

      <dependencyManagement>

          <dependencies>          

             <dependency>

                  <groupId>org.infinispan</groupId>

                  <artifactId>infinispan-bom</artifactId>

                  <version>${version.org.infinispan}</version>

                  <type>pom</type>

                  <scope>import</scope>

              </dependency>

          </dependencies>

      </dependencyManagement>

      ....

       

      And in my module that will use the infinispan-remote dependency I have the following declaration:

       

      <dependencies>

                ....

              <dependency>

                  <groupId>org.infinispan</groupId>

                  <artifactId>infinispan-remote</artifactId>

              </dependency>

                ....

      </dependencies>

       

      So the bom dependency exists, looking into that it references the same version of infinispan-remote which I cant find anywhere, not in maven central, not in jboss public repository. Is this a defect? Otherwise, how is it supposed to work?

      If I switch to version I can find in the repositories (9.1.7.Final) then it works.

       

      Regards

      Andreas