4 Replies Latest reply on Jul 10, 2018 9:05 AM by Luis D P

    wildfly mixed domain

    Luis D P Newbie

      Good Morning,

       

      I had a wildfly domain mode with version 10.1.0 with a Host Controller 10.1.0. I upgrade domain controller to version 13 with jboss-server-migration. I want to have a slave with version 10.1.0. When I start wildfly host controller slave 10.1.0,  I have the following message:

       

       

      [Host Controller] 12:31:38,145 ERROR [org.jboss.as.controller.management-operation] (Host Controller Service Threads - 5) WFLYCTL0013: Operation ("add") failed - address: ([("host-exclude" => "WildFly12.0")]) - failure description:

      "WFLYCTL0248: Invalid value WildFly12.0 for host-release; legal values are [EAP6.3, EAP6.2, WildFly10.0, EAP6.4]"

      [Host Controller] 12:31:38,146 ERROR [org.jboss.as.host.controller] (Host Controller Service Threads - 5) WFLYHC0143: Failed to apply domain-wide configuration from master host controller. Operation outcome: failed. Failure desc

      ription {"WFLYCTL0062: Composite operation failed and was rolled back. Steps that failed:" => {"Operation step-1" => "WFLYCTL0248: Invalid value WildFly12.0 for host-release; legal values are [EAP6.3, EAP6.2, WildFly10.0, EAP6.4]"}}

      [Host Controller] 12:31:38,154 WARN  [org.jboss.as.host.controller] (Controller Boot Thread) WFLYHC0001: Could not connect to remote domain controller remote://192.168.21.215:9999 -- 1-$-

      [Host Controller] 12:31:38,154 WARN  [org.jboss.as.host.controller] (Controller Boot Thread) WFLYHC0147: No domain controller discovery options remain.

      [Host Controller] 12:31:38,154 ERROR [org.jboss.as.host.controller] (Controller Boot Thread) WFLYHC0002: Could not connect to master. Aborting. Error was: java.lang.IllegalStateException: WFLYHC0120: Tried all domain controller

      discovery option(s) but unable to connect

      [Host Controller] 12:31:38,155 FATAL [org.jboss.as.host.controller] (Controller Boot Thread) WFLYHC0178: Aborting with exit code 99

       

       

      Could you help me?

       

      Thanks, Greetings

        • 1. Re: wildfly mixed domain
          simkam Newbie

          Hi,

           

          I'm not sure what exacly migration tool does, but from the error it seems to me, that you try to start WildFly 10.1 with configuration for WildFly 13.

          • 2. Re: wildfly mixed domain
            Luis D P Newbie

            Currently, I have a domain controller with two host controllers in version 10.1. Now I want a DC with version 13 and a HC1 with version 13 and another HC with version 10.1. This way I could execute applications in instances of wildfly that works with version 10.1. It's possible?. According to the Wildfly version 13 documentation:

            WildFly supports "mixed domains" where a later version Domain Controller can manage slaves running previous versions. But those "legacy" slaves can not understand configuration resources, attributes and operations introduced in newer versions. So any attempt to use newer things in the domain wide configuration will fail unless the legacy slaves are ignoring the relevant resources. But ignoring resources will allow the legacy slaves to work fine managing servers using profiles without new concepts, while other hosts can run servers with profiles that take advantage of the latest features.

            With the tool jboss migration tool 1.2.0, I uploaded the version of the DC to version 13. The DC starts me but when I join the HC version 10.1 I get the log message that I put up. Any ideas?

             

            Is there an example of a configuration or site where you can see a configuration of wildfly mixed domains?

             

            Thanks

            • 3. Re: wildfly mixed domain
              Tomaz Cerar Master

              hey,

               

              mixed domain mode is bit of a beast to configure, but in short

              - domain controller (DC) must be the latest between all host controllers (HC)

              - you need to create profiles that target different versions of HC, so that such profile only contains configuration what was valid at that target version

              - usually only EAP versions are supported as target legacy version, as mixed-domain testing and transformers require lots of work

               

              for your case i think you should use target version of EAP 7.0 (WildFly 10.1) or EAP 7.1 (WildFly 11).

               

               

              --

              tomaz

              • 4. Re: wildfly mixed domain
                Luis D P Newbie

                Following your summary,

                 

                - I have uploaded the DC version from 10.1 to 11 with:

                ./jboss-server-migration.sh --source ../wildfly-10.1.0.Final --target ../wildfly-11.0.0.Final

                 

                - Therefore, it would have a Domain Controller with version 11 but with the profile of the 10. I converted all the configuration file domain.xml less the profile I want to use in HC 10.1.

                 

                - I start the DC and all is OK

                 

                - When I start the HC 10.1 that already had failed to join the DC with error message:

                 

                [Host Controller] 13:34:52,696 ERROR [org.jboss.as.controller.management-operation] (Host Controller Service Threads - 5) WFLYCTL0013: Operation ("add") failed - address: ([("host-exclude" => "WildFly10.1")]) - failure description:

                "WFLYCTL0248: Invalid value WildFly10.1 for host-release; legal values are [EAP6.3, EAP6.2, WildFly10.0, EAP6.4]"

                [Host Controller] 13:34:52,698 ERROR [org.jboss.as.host.controller] (Host Controller Service Threads - 5) WFLYHC0143: Failed to apply domain-wide configuration from master host controller. Operation outcome: failed. Failure desc

                ription {"WFLYCTL0062: Composite operation failed and was rolled back. Steps that failed:" => {"Operation step-1" => "WFLYCTL0248: Invalid value WildFly10.1 for host-release; legal values are [EAP6.3, EAP6.2, WildFly10.0, EAP6.4]"}}

                [Host Controller] 13:34:52,719 WARN  [org.jboss.as.host.controller] (Controller Boot Thread) WFLYHC0001: Could not connect to remote domain controller remote://192.168.21.215:9999 -- 1-$-

                [Host Controller] 13:34:52,720 WARN  [org.jboss.as.host.controller] (Controller Boot Thread) WFLYHC0147: No domain controller discovery options remain.

                [Host Controller] 13:34:52,720 ERROR [org.jboss.as.host.controller] (Controller Boot Thread) WFLYHC0002: Could not connect to master. Aborting. Error was: java.lang.IllegalStateException: WFLYHC0120: Tried all domain controller

                discovery option(s) but unable to connect

                [Host Controller] 13:34:52,721 FATAL [org.jboss.as.host.controller] (Controller Boot Thread) WFLYHC0178: Aborting with exit code 99

                 

                 

                It seems like it does not recognize the Host Controller version. Would I miss some configuration in the host.xml or domain.xml?

                 

                Is it possible to run Wildfly profile 10.1 on Wildfly 11?

                 

                I'm stuck.

                 

                Thank you so much