4 Replies Latest reply on Aug 17, 2018 8:48 AM by Roberto Chionna

    Wildfly 13, schema-validation-enabled=false doesn't work

    Roberto Chionna Newbie

      Hello, I'm trying Wildfly 13.

      I need to disable the schema validation in webservice subsystem, so I modified my standalone.xml:

       

      <subsystem xmlns="urn:jboss:domain:webservices:2.0" statistics-enabled="true">

                  <wsdl-host>${jboss.bind.address:127.0.0.1}</wsdl-host>

                  <endpoint-config name="Standard-Endpoint-Config">

                      <property name="schema-validation-enabled" value="false"/>

                  </endpoint-config>

                  <endpoint-config name="Recording-Endpoint-Config">

                      <pre-handler-chain name="recording-handlers" protocol-bindings="##SOAP11_HTTP ##SOAP11_HTTP_MTOM ##SOAP12_HTTP ##SOAP12_HTTP_MTOM">

                          <handler name="RecordingHandler" class="org.jboss.ws.common.invocation.RecordingServerHandler"/>

                      </pre-handler-chain>

                  </endpoint-config>           

                  <client-config name="Standard-Client-Config">

                     <property name="schema-validation-enabled" value="false"/>

                  </client-config>

              </subsystem>

       

      After restarting Wildfly, the schema validation is always active; the same settings in JBoss AS 7.1 works fine.

       

      Thank you very much for any suggestion.

      Have a nice day,

      Roberto