0 Replies Latest reply on Jul 19, 2018 6:07 AM by Manish Manker

    Migrating from Jboss EAP6.3.1 to Jboss EAP 7.0.0

    Manish Manker Newbie

      Hello Folks,

       

      I have an application on EAP 6.3.1 which i am trying to migrate to Jboss EAP 7.0.0.

       

      In EAP 6.3.1, I could see Jboss is skipping optional TLD installation from war while deployment:

       

       

      12:46:15,047 WARN  [org.jboss.as.ee] (MSC service thread 1-4) JBAS011006: Not installing optional component XXXXXXXX due to an exception (enable DEBUG log level to see the cause)

      12:46:15,047 WARN  [org.jboss.as.ee] (MSC service thread 1-4) JBAS011006: Not installing optional component XXXXXXXX due to an exception (enable DEBUG log level to see the cause)

      12:46:15,062 WARN  [org.jboss.as.ee] (MSC service thread 1-4) JBAS011006: Not installing optional component XXXXXXXX due to an exception (enable DEBUG log level to see the cause)

       

      And with this warning, deployment is still successful on EAP 6.3.

       

      But when moving to EAP 7.0.0, Jboss is failing to deploy wars and giving error:

       

      14:49:07,803 ERROR [org.jboss.msc.service.fail] (MSC service thread 1-5) MSC000001: Failed to start service jboss.deployment.unit."XXX.war".POST_MODULE: org.jboss.msc.service.StartException in service jboss.deployment.unit."XXXX.war".POST_MODULE: WFLYSRV0153: Failed to process phase POST_MODULE of deployment "XXXXX.war"

              at org.jboss.as.server.deployment.DeploymentUnitPhaseService.start(DeploymentUnitPhaseService.java:154)

              at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1948)

              at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1881)

              at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)

              at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)

              at java.lang.Thread.run(Thread.java:748)

      Caused by: org.jboss.as.server.deployment.DeploymentUnitProcessingException: java.lang.ClassNotFoundException:XXXX.xxxTLD

       

       

      Please provide any thought/solutions for this.

       

      Thanks in Advance!