0 Replies Latest reply on Jul 25, 2018 12:37 PM by Justin Jeremie

    WFLYSRV0215: Failed to resume activity org.jboss.as.ejb3.component.messagedriven.MessageDrivenComponent$1@17935465. To resume normal operation it is recommended that you restart the server.

    Justin Jeremie Newbie

      Hello,

        After setting up the activemq resource adapter, I get the message described above when I start Wildfly 11. My application is packaged as a WAR which includes an MDB packaged as a JAR. Any idea what might be causing this problem? Thanks.


      MDB code:

      @MessageDriven(name = "ReplyQueueMDB", activationConfig = {

         @ActivationConfigProperty(propertyName = "destinationLookup", propertyValue = "/jms/queue/reply-queue"),
         @ActivationConfigProperty(propertyName = "destinationType", propertyValue = "javax.jms.Queue"),
         @ActivationConfigProperty(propertyName = "user", propertyValue = "buddy"),
         @ActivationConfigProperty(propertyName = "password", propertyValue = "passw0rd")})

      public class ReceiverMDB implements MessageListener {

       

         @Resource(name = "java:/ConnectionFactory")

       

         private static final Logger log = LoggerFactory.getLogger(ReceiverMDB.class);

         @Resource(name = "java:/ConnectionFactory")

         private QueueConnectionFactory queueConnectionFactory;

         @Override
         public void onMessage(Message message) {

       

         try {

         log.info("From R E P L Y queue consumed message: {}", ((TextMessage) message).getText());
         } catch (Exception e) {

         log.error("Error consuming message:", e);
         }

        }

      }

      Relevant sections of standalone-full.xml

      <resource-adapters>

                      <resource-adapter id="activemq-rar.rar">

                          <archive>

                              activemq-rar.rar

                          </archive>

                          <transaction-support>XATransaction</transaction-support>

                          <config-property name="UserName">

                              buddy

                          </config-property>

                          <config-property name="Password">

                              passw0rd

                          </config-property>

                          <config-property name="ServerUrl">

                              tcp://localhost:45549?jms.rmIdFromConnectionId=true

                          </config-property>

                          <connection-definitions>

                              <connection-definition

                                    class-name="org.apache.activemq.ra.ActiveMQManagedConnectionFactory"

                                    jndi-name="java:/ConnectionFactory"

                                    enabled="true"

                                    pool-name="ConnectionFactory">

                                  <xa-pool>

                                      <min-pool-size>1</min-pool-size>

                                      <max-pool-size>20</max-pool-size>

                                      <prefill>false</prefill>

                                      <is-same-rm-override>false</is-same-rm-override>

                                  </xa-pool>

                                  <recovery> 

                                      <recover-credential> 

                                          <user-name>buddy</user-name>

                                          <password>passw0rd</password>

                                      </recover-credential>

                                  </recovery>

                              </connection-definition>

                          </connection-definitions>

                          <admin-objects>

                              <admin-object

                                    class-name="org.apache.activemq.command.ActiveMQQueue"

                                    jndi-name="jms.queue.reply-queue"

                                    use-java-context="true"

                                    pool-name="reply">

                                  <config-property name="PhysicalName">

                                      ReplyQueueMDB

                                  </config-property>

                              </admin-object>

                          </admin-objects>

                      </resource-adapter>

                  </resource-adapters>

       

       

      <subsystem xmlns="urn:jboss:domain:ejb3:5.0">

                  ...

                  <mdb>

                      <resource-adapter-ref resource-adapter-name="activemq-rar.rar"/>

                      <bean-instance-pool-ref pool-name="mdb-strict-max-pool"/>

                  </mdb>

                  <pools>

                      <bean-instance-pools>

                          <strict-max-pool name="slsb-strict-max-pool" derive-size="from-worker-pools" instance-acquisition-timeout="5" instance-acquisition-timeout-unit="MINUTES"/>

                          <strict-max-pool name="mdb-strict-max-pool" derive-size="from-cpu-count" instance-acquisition-timeout="5" instance-acquisition-timeout-unit="MINUTES"/>

                      </bean-instance-pools>

                  </pools>

                  ...

      </subsystem>

       

      <subsystem xmlns="urn:jboss:domain:ee:4.0">

                  ...

                  <default-bindings context-service="java:jboss/ee/concurrency/context/default" datasource="java:jboss/datasources/ExampleDS"

                       jms-connection-factory="java:/ConnectionFactory"

                       managed-executor-service="java:jboss/ee/concurrency/executor/default"

                       managed-scheduled-executor-service="java:jboss/ee/concurrency/scheduler/default"

                       managed-thread-factory="java:jboss/ee/concurrency/factory/default"/>

      </subsystem>