0 Replies Latest reply on Aug 9, 2018 2:03 AM by Oliver Baum

    Could not transfer artifact

    Oliver Baum Newbie

      Hi,

      I'm new with arquillian and shrinkwrap.

       

      I try to use shrinkwrap to load artifacts from the pom for an aquillian test.

      But I always get:

      Jul 04, 2018 10:17:09 AM org.jboss.shrinkwrap.resolver.impl.maven.logging.LogTransferListener transferFailed

      WARNUNG: Failed downloading org/jboss/arquillian/arquillian-bom/1.1.8.Final/arquillian-bom-1.1.8.Final.pom from http://repo1.maven.org/maven2/. Reason:

      org.eclipse.aether.transfer.ArtifactTransferException: Could not transfer artifact org.jboss.arquillian:arquillian-bom:pom:1.1.8.Final from/to central (http://repo1.maven.org/maven2): Error transferring file: Connection refused: connect from http://repo1.maven.org/maven2/org/jboss/arquillian/arquillian-bom/1.1.8.Final/arquillian-bom-1.1.8.Final.pom

       

      Here the code:

      @Deployment

      public static WebArchive  createDeployment()

      {

             

          File[] libs = Maven.resolver()

              .loadPomFromFile("pom.xml")

              .importRuntimeAndTestDependencies()

              .resolve()

              .withTransitivity()

              .asFile();

          .....

      }

       

      I use Eclipse for development.

      When I use maven for compile and deployment everything works.

       

      Can somebody tell me what's wrong?

       

      Thanks for help

       

      Oliver