0 Replies Latest reply on Sep 6, 2018 10:30 AM by bibhusit acharya

    Server Advertise/Mod_Cluster

    bibhusit acharya Newbie

      Hi,

      I have an apache http server(version 2.4.27) sitting in front of two wildfly 10 servers. The apache server acts as a load balancer between the two wildfly servers. I am posting the vitrual host configuration below. I have an issue with unwanted ips hitting my apache. Although they can not access my application( they get a 403 code), I still don't want them hitting my apache. Am I broadcasting and if so how can i disable this? I am using the advertisegroup directive with a custom multicast ip address. I have configured this ip in my wildfly domain.xml as well. I tried with serveradvertise off as well but that did not work. I think it is off by default. Not sure if I have enabled it by mistake. Please help.  

       

       

      <VirtualHost ServerIP:10001>

         DocumentRoot "/opt/app/apache/htdocs"

         <Directory />

      AllowOverride None

         Options None

         Require host Wildfly Host Name1 Wildfly Host Name2

        </Directory>

         # This directive allows you to view mod_cluster status at URL http://<HOST_NAME_APACHE>:10001/mod_cluster-manager

         <Location /mod_cluster-manager>

          SetHandler mod_cluster-manager

      #Order deny,allow

          #Deny from all

          #Allow from all

          Require all granted

          AllowDisplay on

         </Location>

       

       

      KeepAliveTimeout 180

         MaxKeepAliveRequests 0

         ManagerBalancerName main-server-group

         AdvertiseGroup MulticastIp:23364

         AdvertiseFrequency 5

         EnableMCPMReceive on

      </VirtualHost>