7 Replies Latest reply on Sep 17, 2018 10:06 AM by simkam

    "No resource definition is registered for address" error for statistic of resource-adapter during WildFly startup

    Bui Van Nghiem Newbie

      Hi all,

       

      I configure standalone-full-ha.xml to deploy 1 rar archive in WildFly 13.
      Besides, I also have a sar archive to deploy. I use Spring to deploy and expose some mbeans and they depend on below mbean server:

       

          <bean id="mbeanServer" class="java.lang.management.ManagementFactory" factory-method="getPlatformMBeanServer" lazy-init="true"/>

       

      when I start/restart WildFly with both archives in deployment folder. I see below error:

       

      2018-09-14 18:14:49,797 ERROR [MSC service thread 1-3]-[org.jboss.as.controller.management-operation] WFLYCTL0013: Operation ("read-resource-description") failed - address: ([

          ("subsystem" => "resource-adapters"),

          ("resource-adapter" => "my.rar"),

          ("connection-definitions" => "MyResourceAdapter"),

          ("statistics" => "extended")

      ]) - failure description: "WFLYCTL0030: No resource definition is registered for address [

          (\"subsystem\" => \"resource-adapters\"),

          (\"resource-adapter\" => \"my.rar\"),

          (\"connection-definitions\" => \"MyResourceAdapter\"),

          (\"statistics\" => \"extended\")

      ]"

      2018-09-14 18:14:49,797 ERROR [MSC service thread 1-3]-[org.jboss.as.controller.management-operation] WFLYCTL0013: Operation ("read-resource-description") failed - address: ([

          ("subsystem" => "resource-adapters"),

          ("resource-adapter" => "my.rar"),

          ("statistics" => "extended")

      ]) - failure description: "WFLYCTL0030: No resource definition is registered for address [

          (\"subsystem\" => \"resource-adapters\"),

          (\"resource-adapter\" => \"my.rar\"),

          (\"statistics\" => \"extended\")

      ]"

       

      I realize that those errors are printed when above "mbeanServer" bean is initialized. And, it looks like that when WildFly is starting up, models are not populated fully then so I hit above error.

       

      When I start the WildFly with the rar only and wait for start up done, then deploy sar -> no error is printed.


      Big thank if some one can help!